Pause on each layer when printing

Hi all, 
I've been running repetier on my mac for a while, very happy with the results. I have just setup an old windows box I had lying around as my print host. I've found that on each layer, when it gets to a certian point, the printer stops momentarily and then continues. What this does is cuase some imperfections in my print. I can confirm this does not happen on the mac. Is there any way i can stop this from happening. 
Is it possibly a memory issue?



  • It might be that "old" also means "slow". Try disabling filament visualization during print, which binds quite some cpu power. Without it should be no speed problem.
  • Dear @Repetier it used to be a post regarding this, it seems that you cleaned everything,

    i still have this problem, 
    as you already give me the clue (a G4 dwell command) on the gcode)
    i still could not find why Slic3r is adding this commands every random line/position.

    again here it is:

    When Repetier 1.0.6 and slic3r 1.1.7 or 1.2.9 no trouble at all, (no pause commands on the gcode)
    When Repetier 1.5.X and slic3r 1.1.7 or 1.2.9 pause/dwell command con the gcode...

    cant find a solution....
  • I remember the post but did not delete it. Should still be around.

    Before running slic3r the host creates a slic3r.ini file in it's work directory that copies all settings from the slic3r combination you have chosen. So there you should search for G4. In printer tab you can select code on layer switch, so maybe you added there some custom code. I'm using slic3r currently every day without pauses so it must be somewhere in your settings and then it ends in the config send for slicing. You see the exact path in the command line in log which shows how slic3r is called.
  • Here are the two files i tracked, both are the .ini
    could not find the G4.
    Path: C:\Users\UserX\AppData\Local\RepetierHost
    here is a picture of the gcode extra code, nothing there: picture 
    and this is the .gcode with the G4 commands... .gcode
  • According to this slic3r issue

    vibration limit causes G4 to appear and you have vibration limit set to 3! So I guess that might be the problem.
  • edited September 2015
    Dear @Repetier

    Let me test this.

    by now i can assure you this is strictly a slic3r 1.2.9, i have managed to print with any g4 commands added to the code on the Repetier 1.5.5 with slic3r 1.1.7.

    Even with the Vibration limit set to 3Hz, on the 1.1.7 there are no G4 commands.

    I will get back to you.
  • Dear @Repetier  Vibration limit is the cause of the G4 commands.

    it seems that the algorithm used on the new slic3r determines that with a 3Hz vibration limit need to pause. nor on the slic3r  1.1.7

    thanks for the help.

    By the way, i am now testing the Repetier 1.5.5 on a full basis, on a print it stopped, had to hit the manual OK to let the printer goes.
    let me get back to you with more info on this.
  • While com errors can still cause a pause, you can now set a timeout in printer settings and after that time host will flush automatically so manually hitting "ok" is not needed any more. Timeout should be longer then the longest command that is not rated slow (for slow commands timeout is disabled, e.g. heating bed or extruder).
Sign In or Register to comment.