Skeinforge, Repetier Firmware and Host, Initial Retract of approx 50mm

Hello,  I believe this is a Skeinforge configuration issue.  What I am experiencing on some prints is an initial retraction of approx. 50mm, meaning the filament is completely feed out of the nozzle and then hence part will not print.  I have recently switched to repetier firmware and host in order to use Skeinforge.  

I have set my start G-Code to the following including an G92 E0 to set the length of extrusion to 0 for the beginning.

G01 Z2; Moves Z Up
G28; Homes
M190 S100; Sets Bed Temp and waits to heat
M104 S235; Starts Heating and proceeds
G32 S2; Auto Levels
M109 S235; Waits
G92 E0 ;Sets extruder value to 0 for start

Below is the log of commands as I E stopped the printer just as I experienced the issue. One other theory as I have not seen a G-code stating for retract, could the feedrate be set to high that it actually retracts?

19:43:29.680 : Transformation matrix: 0.999999 0.000001 -0.001458 0.000000 1.000000 0.000764 0.001458 -0.000764 0.999999
19:43:29.680 : Free RAM:5022
19:43:29.680 : SelectExtruder:0
19:43:29.883 : N1 M110 *2
19:43:29.885 : N2 M115 *4
19:43:29.889 : N3 M105 *4
19:43:29.906 : Printed filament:4.90m Printing time:0 days 3 hours 56 min
19:43:29.906 : PrinterMode:FFF
19:43:29.906 : N4 M114 *3
19:43:29.912 : N5 M111 S6 *66
19:43:29.915 : N6 T0 *28
19:43:29.918 : DebugLevel:6
19:43:29.918 : SelectExtruder:0
19:43:29.918 : N7 M20 *54
19:43:29.922 : Unknown command:N7 M20
19:43:29.922 : N8 M220 S100 *73
19:43:29.926 : N9 M221 S100 *73
19:43:29.930 : N10 M111 S6 *118
19:43:29.934 : DebugLevel:6
19:43:29.935 : N11 T0 *42
19:43:29.938 : SelectExtruder:0
19:43:29.938 : N12 M80 *8
19:43:31.411 : N13 M105 *53

Any help or pointers is much apperciated.

Thank you!!


  • The log shows nothing of value. It does not contain the heatup or any e moves. Did you close host to finish writing?
  • Did not close the host.  It appears if extruder is not up to temp it retracts after it has been brought to temp with my M104 S235.
  • Ok, there is a setting in firmware 
    /** \brief Temperature to retract filament when extruder is heating up. Overridden if EEPROM activated.
    #define EXT0_WAIT_RETRACT_TEMP 150
    /** \brief Units (mm/inches) to retract filament when extruder is heating up. Overridden if EEPROM activated. Set
    to 0 to disable.

    This is also set in eeprom. So I guess you have set this.
Sign In or Register to comment.