problem with old reprappro huxley

I tried to reactivate my old reprappro huxley (sanguinololo) with the latest repetier host software (1.6.0) on ubuntu 14.04.
Baudrate is 115200. I can connect to the machine and move the x,y and z axis, but extruder and bed is disabled - also startup in the console says number of extruders:0
Any idea what's wrong here?


  • If you say console you mean the log windows? If that says 0 extruder you may have compiled firmware without extruders.
    With repetier firmware make sure to have dry run disabled.
  • Yes by console I mean the log window - on connecting this normally shows a couple of lines from my printer firmware. I used a Marlin v1.x firmware (not the repetier firmware), modified for my hacks (display from think3dprint3d) - normally I used Repetier Host v1.5.5 and v1.5.6 - and everything works fine. I tried pronterface with my old machine and it works fine (extruder and bed is working) - but I relly would like to use the comfort of Repetier Host and the included cura engine and the possibility to change my slicer easy :-)
    I have a Prusa i3 here too and will try the new version on this machine too (also marlin firmware... sorry)
    If I find some time, I will try to post some screenshots and a full output of the log window.

Sign In or Register to comment.