Fatal error at startup


I installed RepetierHost on Linux Debian Wheezy.
Installation looks OK (167 packages added and no error), but when I start RepetierHost, I get that error :

System.Windows.Forms.SplitContainer doesn't implement interface System.ComponentModel.ISupportInitialize


  at RepetierHost.view.RepetierEditor.InitializeComponent () <0x009ea>
  at RepetierHost.view.RepetierEditor..ctor () <0x0019f>
  at (wrapper remoting-invoke-with-check) RepetierHost.view.RepetierEditor..ctor () <0xffffffff>
  at RepetierHost.Main..ctor () <0x00aab>
  at (wrapper remoting-invoke-with-check) RepetierHost.Main..ctor () <0xffffffff>
  at RepetierHost.Program.Main (string[]) <0x00043>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

And a lot of other stack traces. I don't lnow if they are useful...

Thanks for any help.


  • System.Windows.Forms.SplitContainer doesn't implement interface System.ComponentModel.ISupportInitialize

    is the problem. Your mono version is outdated and needs a newer version to run where that function is implemented.

  • Thank you for this information.
    Unfortunately, when I installed RepetierHost, some packages have been installed for mono, taking them from Wheezy stable (know known as "Old stable" !).
    I tried to update, but there is no mono package compatible with "Old stable" in "backport". And the version present in "testing" has widely too much dependencies problems. If I tried to install them, more than 1000 packages would be updated and some removed. I would almost get an unstable system !
    I'll upgrade to Debian 8 sometime. I guess I'll then get the issue fixed... Until that time I cannot use RepetierHost.
  • Version hell can be really a problem. Guess updating to jessy would be easiest solution here. 
Sign In or Register to comment.