Time Lapse on Repetier-Server 0.70.0 on Raspberry Pi

I've got Repetier-server set up and it's capturing images from mjpeg-streamer. I can step through them in the web interface. However the time lapse videos it lists in the interface are zero byte and won't play. I have ffmpeg installed, but is there a certain plugin I should be using or a setting I need to update to get it to generate proper time lapse videos? Is there a way to test or a log fine I could look at to see what's happening? Any help getting me pointed in the right direction would be appreciated..



  • If you have pi with wheezy the ffmpeg version is too old. You get a newer version on ffmpeg version that can do the conversion. You need version 1.1 or higher for video conversion to work. And you should upgrade to 0.70.1.
  • After upgrading to Jessie, I found out that there is no ffmpeg available. Instead, one is advised to use libav (https://wiki.debian.org/ffmpeg). It is stated on the website:
    If you want to use ffmpeg, you will need to change the word "avconv" to "ffmpeg" in the different commands lines. The rest stay the same.

    Where would I have to do that, command lines of the libav module or Repetier Server? Could you please point me to script where I can make these changes?

  • You set the ffmpeg file in global settings->timelapse. There you can also point to libav also I'm not sure it is commandline compatible, but worth a try.
  • So I did that, but it is not command line compatible, the -f concat part of the command is not legal and fails the conversion.
    I was able to manually create the movie out of the images under /var/lib/Repetier-Server/printer/<printername>/timelapse/<timestamp>/ folder using:
    avconv -i 'image_00000%03d.jpg' -r 30 video.mp4

    Of course the name of the file would need to change to one less 0 and 4 instead of 3 if you have more than 999 images.

    Anyone has any idea how the server command line can be changed? or if at all?
  • You can not change it in server. I have modified the server for 0.75 release to detect avconv and then use different settings. Except prepend/append start/end image (which requires the concat filter) it will handle it then correctly.
  • Centus,

    I don't know if this will work, but can you create a bash file that takes all the parameters given by repetier server and converts them to what you need and then call your convert program?

    Thank you,
  • If using Jessie, put this in Global Settings / Timelapse / FFMPEG Path:


    Works like a charm, including watermark.

    Thanks repetier, great job (again)
  • Thanks for this, very helpful in solving my issue.
Sign In or Register to comment.