Webcam issues

I'm printing on my Prusa using Repetier-Server on a raspberry pi 2 for a while now. I'm quite sattisfied how it worked till now.

Last week updated my Repetier-Server software to the latest 0.70.1 version, uploaded the printer settings and the printer was up and running again.

Now I also tried to configure an old USB webcam within Repetier-Server to be able monitoring the prints. I've used the instructions to install a USB webcam on my Raspberry from here:

I've managed to get the webcam working and recieve some images in Repetier-Server. But when I've tried to move the printhead and the bed, it doesn't react annymore.

When I power off the Raspberry, remove the USB cam and power up the PI again, then everything works again when I give some movement orders in Repetier. And it stops reacting when I'm plugging in the webcam again.

Maybe someone is familiar with this issue?

Thanks in advance!


  • Can you please identify the source of problem? The cam software is a independent daemon that offers display over it's own web frontend (port 8080 I think it is). So when this happens does the cam frontend still deliver images? The server acts as a proxy forwarding that stream so it tunnels through extranet if you configured your router. So my question is more is it a webcam server problem or does the repetier-server proxy make problems in that combination.

    Other question - what webcam and resolution did you use? 

    Do you have stable voltage? Not that moving bed makes the pi loose power crashing the webcam. In that case I'd expect the webcam daemon to also not show any images.
  • edited December 2015

    Thanks for your response!

    Maybe my interpretation of your question is wrong.

    But I'm believing I'm using port 8080 for the webcam, since I've also selected this port in the webadresses in Repetier settings. When I start up the Raspberry and Repetier Server (automatically start MJPG-streamer) then I got to see actual images of the webcam in Repetier Server. But I'm not able to activate anny stepper motors (I can still activate and adjust the heaters from this point).

    When I'm stopping the MJPG-streamer with the following command "sudo /etc/init.d/mjpgstreamer stop", The webcam imgage in Repetier get's  blanc, and I'm recieving no more images. But the stepper motors still won't react on anny command from this point.

    I have to shut down the Raspberry (and repetier server running on it), unplug the webcam and start everything up again to get repetier Server (and stepper motors) work again.

    In short: when the webcam is connected to the Pi, only the heaters will work in Repetier. When I disconnect the cam from the Pi, and reboot the PI and Repetier, everything works again.

    The webcam that I use is a brandless chinese one I believe. And I'm configured it at a resolution of 320x240. The Pi and the printer are on seperated power outlets. And the Pi and webcam are not mounted on anny moving parts.

  • Currently that error makes no sense. Please use the console for testing the problem, maybe in a second window. If you can enable the heaters it means you are talking with the firmware so moves should also work. Only if communication stops working no action would work any more of course but that would include heaters. If you are using repetier-firmware send M111 S7 and enable ack/commands in console. Then you should see which commands get send, what firmware thinks it received as well as "ok" returned by firmware. If you see move commands getting send and acknowledged the problem is not on the server side. 

    Then we come to the part not making sense. Since webcam is not connected to the printer I also do not see how it coul dinfluence how firmware works. But maybe with the log we see better the reason and it is the communication that gets a problem.
  • Could it be the power supply for the Raspberry Pi not supplying enough power for the camera?  I have found the additional load on the USB creates a problem.  I have to use a USB hub or a strong 2A+ 5V power supply if I want to connect any significant power devices to the USB on the Pi.
Sign In or Register to comment.