Cannot get M501 to read the EPROMs

Hi I have a 3DP02 printer with a Melzi card running it. Is all seems to drive around ok and I can print a doggy looking print but now I want to calibrate the motives and set the Z axis but I can't seem to get the settings out of the card using pointer face or Repetier-host. Does anyone have some basic instructions on how to do it/ know what could be wrong?


  • In host just open eeprom settings to see them.

    You might have not compiled eeprom support to the firmware.
  • Sorry but how do I do that. I can't see EPROMs setting tab. How do I know if I have complied the firmware. Cheers
  • EEPROm settings in the config menu of host.

    How should I know how you compiled your firmware if you don't? Look into your config if you have enabled the option. In repetier firmware it is EEPROM_MODE set to anything else then 0.
  • Thanks for trying to help. Firmware configure is gray so cannot be selected. I have tried reloading the firmware but still no good. I have windows7 64 bit do us this make a difference? Thanks
  • No Win 7 makes no difference. Are you connected directly or via server. Over server it seems not to work. Otherwise it works very good if communication works.
  • Yes I'm connected direct. So running 64bit Windows should make no difference?
    Can you suggest a direct link so I make sure I'm using the right version of firmware and driver.
    Many thanks in advance
  • Driver is ok if you can connect.

    To test eeprom just send M205 and watch th elog. It should output a long list of settings (repetier firmware assumed).Without eeprom support you get a error message.
  • it comes up with M105 *0 then M105 *6 etc but still the firmware EEPROM configure stays gray
    I don't understand if it connects
  • I meant to say I don't understand if it's connected why it doesn't become active. I know when the firmware was loading it didn't have my Melzi board to select so I just accepted the one on offer
  • M105 is send at the beginning.  Sounds more like you get no understandable connection, so maybe baud rate is wrong. Try 115200 and 250000. Here you find some more infos

    especially how you detect that baud rate was wrong.
Sign In or Register to comment.