com port not detected

Hello, I have looked and looked and can not find a resolution to my issue. I have a Davinci 2.0 running latest Repetier firmware, a Windows 8.1 laptop and a Beagle bone black rev c (Debian 8)  wifi setup. 

I am trying to connect to the printer using Windows installation of  Repetier Server.

My steps are to ssh into BBB, start the server and attempt to add the printer. RS will not see my printers com port which is com3 and the baud rate set to autodetect. I have tried setting separate baud rates as well with no luck. The printer is connected to the BBB via a usb hub. Any assistance is greatly appreciated.   


  • Beagle bone is a linux os and linux has no COMx port numbers. Your port is sometheing like /dev/by-serial/xxxxxxx then server will see it. 

    On windows host select "Server connector". In host 1.6 there is a help button in printer settings explaining it in detail.
  • Thank you for the quick response. I am a newb as you can tell. I had read that the structure that I should use for Linux is

    " COM3= /dev/ttyS2 or /dev/ttyUSB2 or /dev/ttyACM2" I tried all 3 with no success before my original post. I suspect that it is the format I am writing it for Debian 8 Jessie?

  • There is need to guess. The server has a dropdown for available port names, so use that and check which name disappear if you disconnect the printer. I normally use the /dev/by-serial/ port names since they really identify the printer not the type. ttyS2 is definitely wrong. ttyUSB0 for ftdi serial chips and ACM0 for other arduinos.
  • Thank you for that. I did try the drop down and there is nothing there. I think when I get home I will connect the BBB directly to my computer and the printer and see if I can get what I need that way. Will let you know. By the way, I am up to date on the required files so I don't believe that's the issue.

    Thank you again for taking the time to advise.

  • update: Still no joy after direct connection through BBB. The only time I can obtain a com port is with direct connection from my computer to the 3d printer and Repetier Host. Any other suggestions are welcome.
  • On BBB terminal do

    ls /dev/tty*

    one time without connection and one time with connection. The difference is your port for the BBB.
    1. Thank you for that. Sorry be away so long, personal issues. Anyway, I decided to try and get my camera to work and lo and behold the printer connected! Dumb but fortunate luck. I wish I could post why so I could help others with the same problem. My only guess is that I loaded packages that I needed during the camera setup process, Camera not working but will do some more research to try and correct.  Thank you again.
Sign In or Register to comment.