Bed temp get crazy on Repetier Server


Have a Mini Kossel with Ramps 1.4 and Marlin.
ATX to power heating and USB for Arduino.

I have som problem with bed heating.
With Repetier Host everything works fine but on Repetier Server bed temp get crazy, se pictures.
Maybe som power issue but why does it work on Repetier Host.

Need some help with this.




  • Are host and server running on the same computer? Ramps takes power from usb as well as atx so different computers may have different output current.

    Server zooms to a more narrow temperature range, so vibrations are more easy to detect. Your photos don't show the left side with temperature range so I can not say if it is just more visible or a cause by wrong temperature reading.After all temperatures move quickly which is why firmware fires full power. So question is more why firmware measures wrong temperatures. Host/server have no influence on this. Could be a change of reference voltage but anyhow very strange.
  • Server runs on RasberryPI 2, with powerd usb hubb. when host I use win7 lapptop.

    Don´t now why but when I run the server, temp readings jump 5-10 deg. following output. 
    It should not happend as you say, firmware control the temp. 
    Strange is that the temp readings from extruder get the same
    jumping sometimes.

    Showing  a new test.
    In the last picture I run the server on widows laptop and it is working ok. 
    Must be The RaspberryPi doing something wrong.
  • Maybe it is only the usb hub you use. Since it powers the printer it might be a bad power unit with ripples in voltage causing it. I have it on a Pi 2 without these ripples so it must be power untit of pi 2 or hub.
  • Hi.

    Yes it was something with the power from the hub.
    Connected separate 5v to Mega2560/Ramps and no problems.

    Thanks for the help.
Sign In or Register to comment.