Printer does not connect

So, my printer worked perfectly today, and while it was printing, it suddenly stopped. Out of nowhere, it disconnected and when i tried to connect it, i got the error "The given port name does not start with COM/com or does not resolve to a valid serial port". I thought it was a connection problem, so i got a new usb cable(yes i use usb connection) but i still got the same problem. When i touched my power supply, it was very hot to the touch. I took it outside to let it cool down, and now when its room tempature, i tried again but that didnt change anything. I dont know if its a cable that got burnt or something, im just asking if its a common problem.

i use a Printrbot Simple Kit (which is from 2013)


  • Update: im pretty sure my power supply is the problem, because it originally came with a massage machine, and when i tried it on the massage machine, it didnt turn on. and it also had no cooling, probably because a massage machine doesnt draw a lot of power. ill be getting a new power supply and seeing if it will work.
Sign In or Register to comment.