Prusa / Prusaslicer: Inserting pause at layer (M117; M601) causes server to crash

I was printing a part which held a captive nut in a hollow void, so I needed to insert a pause in the gcode to interrupt the print.

The printer reached this line, paused correctly, but after continuing the print from the printer's control, it crashed the rest of the system, stopping all other prints attached to the Pi. 

I tried to recover this print a few times, and each time the system would crash at M117; M601.  I could still see the GUI on the webpage, but it wasn't displaying the machines, and things were generally unresponsive.

I just worked around this for now, but figured it was repeatable enough to mention.  Thanks


  • With server better use
    @pause Change Nut
    to pause a print.

    M117 is send all the times, but M601 is prusa specific. Will test what it does exactly but my guess is that it blocks communication until button on display is pressed. Apart from this it should of course not crash the server.

  • Ok found it. Special case for Prusa using M601 that causes a deadlock. Will be fixed with next release. Actually we replace it with @pause to have better control and solve issues with it anyway, so inserting @pause is the best solution anyway and works already in old version.

    Thanks for the info. It should work none the less of course!
Sign In or Register to comment.