Gcode doesn't work

hello, I'm using Repetier host with the TissueStart printer.  whenever I load a .Gcode file the repetier software recognizes it but when the print starts it prints the last .stl file that was loaded and then sliced (even if there is only the gcode loaded).
It's a big deal because I need to use the .gcode file that I previously modified and not the .gcode obtained with the slicing of the object to print with the direction I want.
at the beginning there wasn't this problem so I would like to know what happened and if it can be changed I don't know with a reset of the printer or something like this).
I already tried to disinstall or reinstall the software.
thank you for your attention, I hope someone will be able to let me know what I can do


  • You can not print stl files. If it would try to do so you should see it in the gcode editor instead of gcode.
    So when you use host directly it will always send the content you see in gcode editor and gcode preview. 

    If you print via sd card or  Repetier-Server it is a bit different. In  Repetier-Server you see the rendering and you can show the 3d view of gcode. If they appear it would print also gcode.

    But make sure the file ending with .gcode really is gcode and not a stl file with wrong extension!
  • edited November 2023
    hi, I tried many ways to print, this is what I did:
    1st option)  load the stl file, slice it on Repetier Host and then modified the gcode with the "editor gcode"
    2nd option) obtained a code with Slic3r and modified the gcode with text edit programs and then loaded the gcode on Repetier Host

    both these ways didn't work, in the first case it printed the gcode obtained with the slicing and not the versione modified with editor gcode.

    could it be that Repetier Host with the printer TissueStart are not able to print a gcode file obtained outside the repeater host path to create a gode?

  • If you print over host and not using sd card at the point you start we make a copy of the editor gcode you see and print that content. Never had someone complaining this does not happen. Should not matter which printer you connect - function is always the same.

    Are you running the latest version on windows?
Sign In or Register to comment.