stl offsets

I'm using command line CuraEngine with my DIY printer through its own interface. I'm encountering an issue where every time I send an STL file to CuraEngine, it changes the origin to the central position of the print bed. However, I've already set the origin in my interface, resulting in my model being moved twice.
Is there an option to avoid changing origin by curaEngine?


  • What do you mean with your interface? Host will center or autoarrange objects on bed - coordinates in cad is not relevant.
  • thank you for answer, I found parameter - machine_center_is_zero. That is what I was looking for.
  • Unfortunately, the parameter - machine_center_is_zero is not what I am looking for. The situation is as follows: I am sending an STL file that is already offset (object centered on the print bed with an offset of X=100, Y=100). Additionally, I am providing the print bed width and height to CuraEngine as parameters X=200mm, Y=200mm. The generated G-code is positioned around X=200, Y=200. It seems like CuraEngine is considering two offset parameters - one from the STL file and the second from half of the print bed size. How can I disable or turn off one of these offsets?

  • Offset in STL is not relevant. You can not provide bed position in cureengine config in host. It uses the settings in Printer Settings and there you must define x min and y min and bed front and bed left with -100 if your center is 0 and size is 200.
Sign In or Register to comment.