filament sensor for Creality Ender 3 S1 not stopping when filament runs out

The printer has a filament center built in and it definitely works for gcode running on the printer itself.

I have Repetier-server 1.4.4 running on a pi. The filament sensor definitely sees that the filament has run out but the job does not stop when the Gcode comes through this device. The printer just continues to print.

Is Repetier server doing something to disable this built-in printer functionality? Or do I just have something not set up correct??

I've been very happy with Repetier for about a decade and I'd hate to move off because of this.


  • We need a message from the firmware to react on it. Some are compiled to send no signal when printing via host and some need a command to enable it. Check if it already writes some message on out of filament. If not check if M412 is supported:

    If so put enable filament sensore host support command in start job commands in server.
    M412 H1 S1

  • hi i have the same problem with sidewinder x1 and x2 server run in windows  what i need to do?
    im starting with repetier server im a new membrer 
  • With the original sidewinder X1 firmware I have it did not work. I used to connect the sensor to my pi instead and use the pi pin I connected it to to trigger filament change. Now working on better klipper integration (next 1.4.14 release) I converted the sidewinder x1 to klipper with filament sensor support natively. But also a alternative marlin firmware with host sensor support would work. Have no X2 but guess it is the same problem. But you can try if M412 works:

    M412 S1 H1

    If so add it to run before job g-code in server config to enable it for printing.
Sign In or Register to comment.