Skipping steps on Print cancel. skipping steps when starting timelapse

Its getting very annoying. i've wasted well over 1kg of filament because it keeps skipping steps. I started a timelapse and immediately it skipped steps. when I cancel a print, it skips steps and I have to reset my eeprom to get it to home again. what is going on?


  • okay you guys gotta fix this because update: no skipped steps on my motion test gcode with repetier-host. I really want this to work because the software is very convenient and I paid $5 to the pateron. 
    more pc info:
    Old laptop
    Intel i5-2410M 2.3GHZ
    6GB RAM
    Windows 10 (thinking about going to ubuntu server)

    I didn't have this problem running off my pc with much more adequate specs, not enough ram on laptop? when I run my motion test off the server, it skips steps at the exact same spot, it seems like something with the buffer

  • I have all the run on event gcodes blank, so that's probably not it
  • the only difference I see in my settings is the communication timeout is set to 40 in host and 3 in server. sorry for all the posts
  • 3D printer info:
    SKR 1.4 (not pro or turbo)
    TMC2209 all axis
    USB serial connection
    baud 250000
  • running fine on my desktop. must be something with my laptop hardware. will try switching to ubuntu soon
  • What do you mean with skipping steps? My definition is that motors loose steps so print is not aligned any more. Printer firmware is responsible to prevent this by plannign the path and accelerations so this will not happen.

    When you say it happens on timelapse I guess you have configured it to make it at a special position. In that case check the move speeds defined in printer setup->General->Manual control. Maybe the speed is too high for your printer to handle. Also in that case you better reduce max speed in printer eeprom settings so no one can use speeds causing loosing steps. Other things to maybe adjust is acceleration and jerk. Disable checking endstops during print to not make false (cross talk introduced) signals making motors stop as well.

    And last you can enable logging to check if there are communication errors that add extra stops. Timeout 3 is ok if firmware supports busy protocal. Enable ack in console and run G4 S10 and see if you see some "busy" messages appear. Then it is supported already.
  • edited September 2023
    okay so the problem isn't solely on repetier-server. something probably went wrong with my printer somehow and its not letting me print at the same speeds it used to. It works when I slow it way down to the speeds before I upgraded it, but repetier-server seems to be exaggerating the problem as it passes my simple motion test and doesn't skip as many steps as when I run it with repetier-host. I am overdue for an upgrade to 24v from 12v, so that may help. I am getting a new motherboard and I'm going to give klipper a try. Might give the raspberry pi version a try
  • Check console. Sounds like your connection settings are wrong, e.g. input buffer to big so you get lots of resend requests from printer loosing received data. When you send more then printer can buffer this happens and resend to get in sync slow down everything.
Sign In or Register to comment.