Push Messages not being sent

edited September 2023 in Repetier-Server
My SD Card failed and so I have re-installed the latest version and reconfigured the server. I have been trying to set back up my Push Messages with no luck. I have tried Repeater-Informer, which was working as expected before the SD Card failure.

My Group Key is : DPZL8-489P8-378RS-UWU94-G8772 and I see the message in the server.log

2023-09-10 16:25:28: Repetier-Informer API response: {"error":1008,"errorMessage":"No one listening for group"}

As this was not working I then turned to Pushover. I have a working API (I don't want to paste the API Token/Key and my user key) and can test it via a bash script which delivers the message. How ever sending from Repetier-Server the log returns.

2023-09-10 16:32:20: Push Over API response: {"token":"invalid","errors":["application token is invalid, see https://pushover.net/api"],"status":0,"request":"282536df-f54b-4fbc-be99-7df86a6bc8fd"}

I haven't had this problem before, everything work out out of the gate.


  • Just a quick update. I have a lot to get through printing wise so I have re-installed V1.4.10 and the push messages are working again. Only using pushover though as I can attach an image to the message. 
  • Regarding server, it is working. But there is no group with your id so nothing to send to. If you see it on your phone, delete it and create a new one.

    Pushover is a bit strange. First tets said

    5:08:32.362: Push Over API response: {"info":"no active devices to send to","status":1,"request":"2a0455ca-e23e-4c3e-8990-882143d0da69"}

    and later messages where I wanted to debug worked

    15:57:12.098: Push Over API response: {"status":1,"request":"c946129f-fe4f-4c66-8f2b-c1dad1796996"}

    15:57:34.012: Push Over API response: {"status":1,"request":"1fe9a75c-6cd7-41cb-b8a1-71c7e5e4010b"}

    15:57:57.698: Push Over API response: {"status":1,"request":"86e367f0-be90-4814-ae67-b1b0ae7f879e"}

    From your message it seems like it did not know your token or it was wrong when you tested. Since we also did not touch that function I assume it still works in general just that it had bad token value for the test.
  • edited September 2023
    Yes, I tried recreating the API keey using the link provide in the Push Messages. I spent a good couple of hours trouble shooting both Pushover & Informer. I was able to send messages to Pushover via a bash script and recived that message on my iphone. I could not no matter how many times I started over with API keys or Informer Groups.

    Reinstalling 1.4.10 work as expected using the same API Key & Informer Group I was trying to use with 1.4.12. 

    2023-09-12 07:35:40: Repetier-Informer API response: {"error":0,"data":{"receivers":1}}

    2023-09-12 07:36:35: Push Over API response: {"status":1,"request":"187c66bb-f698-438d-b446-52a305a4f09b"}

    Very strange. 

    I will upgrade to 1.4.13 when its released as for now I can't afford for my server to be off-line for the next few days.

Sign In or Register to comment.