Suppor request (licensed version) - Issue after update to latest version - server not running

Hello, after update to latest version I tried to upload new gcode and during the upload the server suddenly disconnected the upload. Upon that server never went to alive again. Screen on Pi is black, and when I tried to connect I got this error message:

   Repetier-Server currently not avaliable

It seems that Repetier-Server is currently not running. Retrying in 28 seconds.

If it does not restart in a reasonable time, the service might be stopped. You can restart the service in a terminal windows sending the command:

sudo service RepetierServer restart

If it fails to start as a service start it manually. You will see the logging on the terminal and will help you hopefully to identify the problem.

export LC_ALL=C sudo -u repetierserver /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml
Sudo service repetitierserver restart did not helped at all, situation remains.

I tried to do the second command but for me it wont tell anything, I would like to request urgent help if possible :(

Logs exported:
Reading server settings...
16:50:42.553: Repetier-Server 1.4.11
16:50:42.555: Imported external command Shutdown Server
16:50:42.555: Imported external command Reboot Server
16:50:42.555: Imported allowed execute command shutdown
16:50:42.555: Imported allowed execute command reboot
16:50:42.555: Webdirectory: /usr/local/Repetier-Server/www/
16:50:42.555: Storage directory: /var/lib/Repetier-Server/
16:50:42.556: Configuration file: /usr/local/Repetier-Server/etc/RepetierServer.xml
16:50:42.556: Directory for temporary files: /tmp/
16:50:42.556: Reading firmware data ...
16:50:42.705: Starting Network ...
16:50:42.705: Active features:4095
16:50:42.705: Starting user database ...
16:50:42.706: Reading printer configurations ...
16:50:42.715: Reading printer config /var/lib/Repetier-Server/configs/Prusa_MK3SMMU2S_01.xml
16:50:42.723: Starting printjob manager thread for Prusa_MK3SMMU2S_01
16:50:42.723: Starting work dispatcher subsystem ...
16:50:42.725: Importing projects ...
16:50:42.766: Importing wifi connections from /var/lib/Repetier-Server/database/repetier-network.xml
16:50:42.767: Importing wifi connections from /var/lib/Repetier-Server/database/repetier-network-stored.xml
16:50:42.767: Initializing LUA ...
16:50:42.768: Starting wifi watcher ...
16:50:42.774: Register LUA cloud services
16:50:42.774: add G-Code-Renderer
16:50:42.774: LUA initalization finished.
16:50:42.775: Work dispatcher thread started.
16:50:42.775: Starting printer threads ...
16:50:42.775: Internal work dispatcher thread started.
16:50:42.776: Setting up MQTT Client ...
16:50:42.776: Starting web server ...
16:50:42.776: Project Job:gcode#b5cb7990-34a5-4d14-8923-0a1e7784de2f#/var/lib/Repetier-Server/projects/Objednavky.dir/PaxE/files/OrderPart01_0.4n_0.3mm_PLA_MK3SMMU2S_3h48m.gcode


  • removed the latest dir I uploaded and tried to reboot server helped.
    (had to learn few linux commands :) )
    Then I noticed even newer update which solves this issue. 

    Issue resolved probably :)
  • Yes, that update fixes exactly that bug and since it could crash server we made an instant release for it.
Sign In or Register to comment.