several issues of iFactory3D OnePro.

Hey guys,

Just registered an accoutn here to see if anyone is able to help me solve my issues.
About 1 month ago i got my iFactory3D One Pro printer.
After only 2-5 hours of printtime i started getting error messages saying "buffert memory error", shortly after this the printer even stopped booting up.

I reinstalled the software for the rasberry on a new SDcard and tried again.
This time i noticed that the free space on the card kept declining, after about 3 hours of just being turned on but not doing any work the free space had gone from several Gb to about 600mb.
So it seems to keep writing new things onto the card that sooner or later crashes the card and makes it unable to boot up.

Any ideas what could be causing this?

My second issue is that the printer shows as offline both in the interface and on the screen directly connected to the Pi.
This issue happened once or twice befor the reinstall aswell, but a restart solved it.
Now after the reinstall nothing seems to help me get the porinter to show as online.

im fairly new to repetier, octopi and all those softwares, so consider me rather nood. :)


  • Normally printing does not use much sd card space, but there are 3 things that can do this:
    - Logging enbaled
    - Rescue function enabled
    - Timelapse videos - this can use lots of gb if you have hires storing it every few seconds. So check what you have set here. A good choice is selecting every 0.1mm to get one image per layer.

    So check if one of these is enabled and improve setting. First two have only mild impact, only timelapse can get really fat also it normally stops 500mg before disk is full to protect filesystem.

    If it is none of these, you need to find out what part is taking so much disk space. Login to pi via ssh and select a folder eg. with
    cd /var/lib/Repetier-Server
    sudo du -sh *

    and you see which folder takes how much memory. If it is that big it should be easy to find where the big data goes to and then solving it is easy.

    When settings worked before and it does not connect any more even after repowering, check connection settings. Don't know what you selected as port but some variants can change name, e.g. /dev/serial/by-path depends on port you connect printer to. by-id should always be the same if no firmware update changes signature.

Sign In or Register to comment.