I'm so tired

God, this is the BEST software that ALWAYS works and has NO issues WHATSOEVER.

I've been having trouble trying to use PrusaSlicer with RepetierHost for weeks now.

It started with a generated G-code error, where it couldn't find the file name. It was extra fun dealing with this one, as the error popup window REFUSED to be resized, so i couldn't read the whole error message, and it wasn't showing up in the logs. After having solved this issue by creating a new directory SPECIFICALLY for Prusaslicer, it was able to locate the Gcode. Only for....

RepetierHost to have it's own hissyfit, as for whatever reason, it didn't have permission to access the folder. No matter what I tried, Repetier DID NOT want to have permission for that folder. The best part however, was the fact that this affected ALL of my slicers, so Cura and Slic3r didn't work either. I "fixed" it, by removing the directory. Logic would assume that this would revert Prusaslicer back to having the same error as before, expect.....

Now, Prusaslicer doesn't work at ALL. When I try to slice ANYTHING with the damn thing, it just freezes the whole software, forcing me to have to xkill the app just to use my computer again.

I typically don't act like this, and I hate to be sarcastic, but  I've been effectively banging my head against a brick wall for over 2 weeks now, and this happens EVER TIME I leave the software for over 3 seconds. This is excluding the amount of time's I've had to re-download the software as a hard reset. 

I'm using Ubuntu 22.04, and have the latest AppImage of RepetierHost. If there is ANYTHING that I can do to fix the onslaught of bugs I'm facing every time I uses this thing, please let me know.


  • I just tested on ubuntu 22.04 and it sliced my gcode right away to the default workspace.
    It is important that the host is started from the same user as the work directory is owned by.

    I used the build in PrusaSLicer with default settings.

    If you disable easy mode you also see the communication with PrusaSlicer in the log at bottom in case you need to make it wider. I get some mount/permission errors from slicer but nothing stopping it:
    08:23:55.942 : PrusaSlicer command:/tmp/.mount_RepetiFOKHsL/Slic3rPE/slic3r-console.exe --load "slic3r_settings.ini" --dont-arrange --export-gcode --output "composition.gcode" "composition.amf"
    08:23:55.992 : Preferred name from tablet to tablet
    08:23:56.413 : <PrusaSlicer> [2023-04-11 08:23:56.400504] [0x00007fc6b7746900] [trace]   Initializing StaticPrintConfigs
    08:24:03.111 : <PrusaSlicer> 10 => Processing triangulated mesh
    08:24:03.119 : <PrusaSlicer> 20 => Generating perimeters
    08:24:03.126 : <PrusaSlicer> 70 => Infilling layers
    08:24:03.128 : <PrusaSlicer> 30 => Preparing infill
    08:24:03.129 : <PrusaSlicer> 88 => Generating skirt and brim
    08:24:03.130 : <PrusaSlicer> 90 => Exporting G-code to composition.gcode
    08:24:03.134 : <PrusaSlicer> Slicing result exported to composition.gcode
    08:27:06.568 : PrusaSlicer command:/tmp/.mount_RepetiFOKHsL/Slic3rPE/slic3r-console.exe  --datadir "/home/parallels/.Slic3rPE"
    08:27:06.762 : <PrusaSlicer> [2023-04-11 08:27:06.762179] [0x00007fe5ccf0b900] [trace]   Initializing StaticPrintConfigs
    08:27:06.930 : <PrusaSlicer> Gtk-Message: 08:27:06.930: Failed to load module "canberra-gtk-module"
    08:27:07.750 : <PrusaSlicer> libGL error: pci id for fd 14: 1ab8:0010, driver (null)
    08:27:07.905 : <PrusaSlicer> pci id for fd 15: 1ab8:0010, driver (null)
    08:31:49.451 : <PrusaSlicer> update.go:85: cannot change mount namespace according to change mount (/var/lib/snapd/hostfs/usr/share/gimp/2.0/help /usr/share/gimp/2.0/help none bind,ro 0 0): cannot open directory "/var/lib": permission denied
    08:31:49.463 : <PrusaSlicer> update.go:85: cannot change mount namespace according to change mount (/var/lib/snapd/hostfs/usr/share/xubuntu-docs /usr/share/xubuntu-docs none bind,ro 0 0): cannot open directory "/var/lib": permission denied
    08:31:50.779 : <PrusaSlicer> Gtk-Message: 08:31:50.779: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.
    08:31:52.643 : <PrusaSlicer> [GFX1-]: glxtest: VA-API test failed: failed to initialise VAAPI connection.
    08:31:52.901 : <PrusaSlicer> ATTENTION: default value of option mesa_glthread overridden by environment.
    08:33:12.295 : <PrusaSlicer> ALSA lib conf.c:4120:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
    08:33:12.310 : <PrusaSlicer> ALSA lib seq.c:935:(snd_seq_open_noupdate) Unknown SEQ default

    So at the moment I have no real idea what you do different causing it. All is stored in ~/.local/share/RepetierHost and that is owned by my user as it it a subfolder and all higher folders are also owned by it.

    How does you failing log look like? Maybe it gives a hint to my you overlooked.

  • Alright, so with a bit of tinkering, I managed to get Prusaslicer to work exactly ONCE, everytime I open Repetier.

    After that one slice I get, the software sends me an error once as well, being

    System.ComponentModel.Win32Exception  (0x80004005): ApplicationName=' /home/user/.local/share/RepetierHost/composition.gcode'. CommandLine='

    I can't read the rest of it, as it's cut off, and for whatever reason I can't scroll to the right still. I just don't have a scroll bar to even use, so I can't read the rest of it.

    On the plus side, I got Slic3r to stop pillowing everything under the sun, so in the mean time I can go back to that software.

    Thanks for the help.
  • At least if you check it at the bottom with easy mode off you can mark the lines and copy content to clipboard to see everything.
    Unfortunately 0x80004005 is just unspecified error so no real info. When you see the commandline you might run it directly from terminal and see if that causes an error on screen not visible in host. Since the file does not exist it is likely a problem in prusaslicer, also I just tried multiple invocations from host with no issue.
Sign In or Register to comment.