Generated G-code not found

Ok, so I'm having a fun time with the BEST game ever.

For whatever reason, when I'm trying to do a slice with Prusaslicer, and I've gotten nothing but the

 Generated G-Code Not F:ound.

But wait, there's more.
This only happens on occasion. If I close and re-open the software a couple dozen times, or I restart my entire computer, then it'll work just fine, without any issues. 

I have no clue how I even managed this. I'm running Ubuntu 22.04, and I've got the latest version of each software needed. Little help?


  • You should see an error screen with everything PrusaSlicer did say. When this happens normally a setting is not allowed in combination, e.g. layer height 0.5 with 0.4mm nozzle is not allowed. But only reading the output can tell you what did go wrong.
  • Alright, So I've tried every possible recommended pre-made configuration for Prusaslicer I can find, an I just keep getting the same error message.

    So, deciding to throw that out of the window, I just decided to create a new directory, so that Prusa can stop saving the gcode to where ever it feels like it.

    with the new directory of /home/username/.local/share/RepetierHost/composition.gcode, I'm now getting a different error. So some progress has been made.

    Thankfully, it's not a completely random error, as I'm just getting a Permission Denied message, telling me that RepetierHost doesn't have access to the new folder. 

    Is there anything you recommend me to do from this stage? I think I can fix it myself, but I'm not 100% confident that RepetierHost would survive.
  • edited April 26
    I'm getting the same error, G-code not found. Designing in Fusion 360 and sending to Repetier Host.
    Design is a simple 3" disk, .175 in thick, for Garmin Vacuum base. I intend to use the smooth side from the class on the bead for the vacuum side and stick the disk to the dash of my truck with double sided tape.
    I've been using Fusion 360 with Repetier Host for years and never had this problem before. I always update Host to the latest version...

    BTW, I get the same error using Slic3r, Prussia Slic3r, and Cura Engine provided with Repetier Host.

  • What is the output in log from slicer? Is this also in ubuntu or windows?
Sign In or Register to comment.