Post print cooldown but I don't want it

For some of my prints I don't want a post print cool down because I'm printing another model (color) over top and don't want the print to release from the bed. So I comment out the cool down g-codes from my end script in the slicer. But Repetier Server still cools down the printer at the end of a print. If I print through Pronterface this doesn't happen.

How can I disable this 'feature', automatic cool down?


  • There is no feature for automatic cooldown, but server has some event dependent scripts in it's configuration, see gcodes->event dependend->Run after print in this case. After slicers gcode is run that is executed in addition and there might be also a disable heaters from initial setup.
  • Yeah, that was it, cool down was in the default Run After Print script. Thanks for the quick response.

    If the feature isn't 'built in' but in the default Run After Print script, its still a 'feature' of the software.

  • To disable the automatic cool down feature in Repetier Server, you can try the following steps:

    1. Open Repetier Server and navigate to the Printer Settings page.
    2. Select the printer for which you want to disable the cool down feature.
    3. Scroll down to the G-Code section and locate the "End G-Code" field.
    4. Check if there are any cool down G-codes in this field and remove them if they are present.
    5. Save the settings and try printing again to see if the cool down feature has been disabled.

    If the above steps do not work, you can also try disabling the "Automatic fan off" and "Automatic extruder off" options in the Printer Settings page, as these may also be contributing to the cool down process.

Sign In or Register to comment.