i get this error when i try to open slic3r

I am getting a 0x80004005 error when I try to open slic3r config inside repetier-host.

20:09:30.414 : System.ComponentModel.Win32Exception (0x80004005): The requested operation requires elevation

at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)

at RepetierHost.view.slicer.Slic3rInstance.RunConfig()

I can open slic3r stand alone with no issue.

I tried running RH as admin, reinstalling RH, SFC /scannow.

It previously worked.

windows 10 desktop

RH 1.5.4

slic3r 1.2.9a

same RH installed on W10 laptop works fine.

any ideas


  • And for me it still works. After googling it seems this message means the program needs admin privileges and does not get them. If you installed it you had the rights so that makes not much sense if you haven't changed it. And starting it manually should need the same rights. Have you already tried rebooting?
  • not sure what fixed it. I had set Slic3r to run as admin for some reason (probably thought it would fix something). Then I ended up reinstalling everything and then upgrading to RH 1.5.5. Still broke, then I removed run as admin and it is working.
    thks for ur support.
Sign In or Register to comment.