Alafwise U30

Hello everyone,
I have the big problem that I can't connect my Alfawise U30 printer to my Raspberry pi 4.
When I add a printer and choose whatever port it chooses, it always connects, but then complains that the firmware doesn't match.
at first I thought that the printer was my problem, but with pronterface I can connect and control the printer without any problems. The Raspberry pi has also been flashed again, but no improvement.
I'm slowly at the end of my advice as to what else it can be.
Can someone help me what I have to do to make it work.


  • What does M115 show as firmware?

    If you are sure you have selected the corerect firmware (Marlin I guess) you can just ignore it if baudrate is correct. The message just means we did not see some response we expected. Might be that firmware has changed that string. So if everthing works after ignoring this that is ok.
  • If I ignore this message, it connects, but fails the ping pong test.
    and when i leave the settings, it shows me that the printer is connected, but i can't see any values or control any movement.
    I'll try M115.
  • Have just looked after the commands. The current temperatures are displayed in Pronterface and I can also control the printer. If I send the M18 S200 or control commands, it also executes them, but gives me no feedback in the console, just like the M115, which says only sends M115 and that's it. No respond.
  • If commands like M114 show no response (some are filtered depending on switches at top) you might need to change the dtr or rts state ending with the opposite and try again. Some printers use hardware flow control and stop sending on a certain state.
  • Have tested all RTS and all DTR positions with all ports that the RPi showed me. He always said connected and then came the error message that the firmware is not the right one.
    Why can Pronterface read the temperatures and control the printer and the RPi not?
  • Here is a picture of the commands I have already tried in Pronterface and the feedback
  • What firmware is that? In Pronterface the responses do not look really like a supported firmware. M115 is query for firmware and some firmware details and it returns coordinates or m18. Do you know the firmware name used in that printer?
  • Firmware Version is V2.15 13:12:37 Nov 22 2018
  • I am also very surprised that I can control the temperature and movement in Pronterface, but cannot send / receive commands.
  • Here is a picture of the info tab from the printer. 
  • V2.15 is a version number, but does not say which firmware it is. Googling I find often refernces to longer but also marlin firmwares. So it might be modified marlin where they have own version numbers. Just for comparison here a marlin 2.1 response on M115

    Send:9:40:24.279: N4 M115 ; Get firmware capabilities and info
    Recv:9:40:24.295: FIRMWARE_NAME:Marlin 2.1.2 (knutwurst, Github) (Dec 26 2022 14:39:39) PROTOCOL_VERSION:1.0 MACHINE_TYPE:Knutwurst's Anycubic Printer EXTRUDER_COUNT:1 UUID:b6153152-86fb-4cd8-bda7-91c6a04c467d
    Recv:9:40:24.295: Cap:SERIAL_XON_XOFF:0
    Recv:9:40:24.296: Cap:BINARY_FILE_TRANSFER:0
    Recv:9:40:24.297: Cap:EEPROM:1
    Recv:9:40:24.297: Cap:VOLUMETRIC:1
    Recv:9:40:24.297: Cap:AUTOREPORT_POS:0
    Recv:9:40:24.298: Cap:AUTOREPORT_TEMP:1
    Recv:9:40:24.299: Cap:PROGRESS:0
    Recv:9:40:24.300: Cap:PRINT_JOB:1
    Recv:9:40:24.300: Cap:AUTOLEVEL:0
    Recv:9:40:24.300: Cap:RUNOUT:0
    Recv:9:40:24.303: Cap:Z_PROBE:0
    Recv:9:40:24.303: Cap:LEVELING_DATA:1
    Recv:9:40:24.303: Cap:BUILD_PERCENT:0
    Recv:9:40:24.304: Cap:SOFTWARE_POWER:0
    Recv:9:40:24.304: Cap:TOGGLE_LIGHTS:0
    Recv:9:40:24.305: Cap:CASE_LIGHT_BRIGHTNESS:0
    Recv:9:40:24.307: Cap:EMERGENCY_PARSER:1
    Recv:9:40:24.308: Cap:HOST_ACTION_COMMANDS:1
    Recv:9:40:24.308: Cap:PROMPT_SUPPORT:1
    Send:9:40:24.308: M876 P1
    Recv:9:40:24.309: Cap:SDCARD:1
    Recv:9:40:24.309: Cap:MULTI_VOLUME:0
    Recv:9:40:24.310: Cap:REPEAT:1
    Recv:9:40:24.310: Cap:SD_WRITE:1
    Recv:9:40:24.312: Cap:AUTOREPORT_SD_STATUS:0
    Recv:9:40:24.312: Cap:LONG_FILENAME:0
    Recv:9:40:24.313: Cap:LFN_WRITE:0
    Recv:9:40:24.315: Cap:CUSTOM_FIRMWARE_UPLOAD:0
    Recv:9:40:24.315: Cap:EXTENDED_M20:0
    Recv:9:40:24.318: Cap:THERMAL_PROTECTION:1
    Recv:9:40:24.318: Cap:MOTION_MODES:0
    Recv:9:40:24.318: Cap:ARCS:1
    Recv:9:40:24.318: Cap:BABYSTEPPING:1
    Recv:9:40:24.320: Cap:CHAMBER_TEMPERATURE:0
    Recv:9:40:24.321: Cap:COOLER_TEMPERATURE:0
    Recv:9:40:24.321: Cap:MEATPACK:1
    Recv:9:40:24.321: Cap:CONFIG_EXPORT:0

    Also the age of 2018 indicates in could be marlin 1.x version but even marlin 1.x behaves different.

    Is Pronterface working correctly when you print a file with that?

  • The problem with me is that the Pronterface doesn't reply to me at all about the firmware version. I haven't printed anything via pronterface yet, but I can imagine that it will run without any problems because I can move the printer and control the temperatures. Can it be that my firmware on the printer is wrong? And maybe an idea how to fix that?

  • At least firmware is old. When I googled it I saw newer firmware and several marlin versions as well. But you should be comfortable with changing firmwares since it might make things worse if they are configured wrong.

    Due to the wrong answers it will always show the wrong firmware in our wizard, but should work otherwise. To work it just must answer commands with "ok". Saying this I did not see it in Pronterface, but think you had a filter enabled to not flood the output with these messages. Maybe there is more being filtered by Pronterface. Same is with our server console. It has by default all filters enabled to only let important messages pass.
  • i have tried to upload a new firmware, buck I can't get a connection between and the printer. Any ideas? 
  • If it is same as where server runs disable the printer in server. Only one software can access a port at a time otherwise it is blocked or gets errors depending on os. Also uses first serial it sees, so make sure only one printer is visible and no other serial devies are connected.
  • In that case I had nothing else open except Visual Studio Code. The right port was also selected. I can imagine that the motherboard is somehow locked? Maybe that's also the reason why the RPi with repertie server can't access the printer?
  • Do you know the processor? Especially 32 bit boards often need either a file on sd card or to be put in boot mode. 8 bit boards use a bootloader and can only update if it has a bootloader or you would need special hardware tp upload. Normally all can update since there is always the chance of firmware issues and if a company can provide an update it is cheaper to fix.

    If it uses avrdude it is a 8 bit board. It sometimes fails for no real reason and you just retry it and suddenly it works. Make sure main power is off during upload if that is possible without loosing the usb serial port.
  • The Processor is a STM32. 
  • for most stm32 board you need to copy the file firmware.bin (int .pio/... subfolder) to sd card which you insert into printer and on next power up it installs the file and renames it to firmware.cur which is handy to verify it got installed.

    For upload via usb you must put the stm32 into dfu mode. Some have a switch on board others need to hold boot button while you press and release reset button on board. After that device shows up with different id and upload with dfu uploader will work.
  • Now I have changed the Mainboard to a skr mini e3 v2, loaded the ender firmware with other dimension on it and now it works perfectly. But thanks for your help.
    But now I have a other question, is it possible to load gcode form a network drive, for example a NAS or server with SMB? 
  • For importing from other places like usb drives or samba you can define folders is global settings. You reach them then in the interface with the dropdown right to the upload button.

    What you need in addition is make linux mount your smb drive so you can point to that mount point. So linux does the network access and we just read the folder. Google samba for more details. Samba is the linux package for smb mounts.
  • one last question, is it possible to add a DS18b20 temperature sensor to monitor the enclosure temp. and turn a heater on and off? 
  • Only if it is firmware side as heated chamber implemented. If firmware reports it with C: in response and accepts M141 for heated chamber you can use it. If your firmware does not support it you need to add a wizard or some other solution in server to control it with some scripts.
  • I mean over the RPI not over the printer. I would like to see the temp. on the web server and on the Touchscreen.
  • If you can read temperature in bash scripts you can add it in the hardware info menu (bolt icon) in the interfaces. It is in /var/lib/Repetier/Server/scripts and you should see how the other lines are written. Use same system with other value.

    For setting write a wizard that asks the temperature and set it with calling a script using @execute scriptname value. See advanced chapter in manual on how to add own external scripts to extcommands.xml
  • Okay, i will try that.
    Thanks a lot for your help.
Sign In or Register to comment.