change filament go crazy after update to 1.4.8

raspberry pi 3 + touchscreen 7''

I updated my raspberry pi from 1.4.4 to 1.4.8 by using the update function.
After the update the option to change filament seemed to go crazy. 
I set the loading with 300mm Fast Distance and 50mm slow Distance, with 1.4.4 it worked perfectly, 
now it loads about double ... I solved it for the moment by setting 180mm and 30mm 
just to not break the printer but actually it loads 
about 300mm Fast and 50mm Slow with the values ​​set to 180mm and 30mm


  • When I test this with your values I get this commands send in console:

    Send:8:47:39.824: @moveRel E300.0000 F20
    Send:8:47:39.825: N44 M82
    Send:8:47:39.825: N45 G92 E24.0000
    Send:8:47:39.826: N46 G1 E74.00 F1200
    Send:8:47:39.826: N47 M82
    Send:8:47:39.826: N48 G92 E24.0000
    Send:8:47:39.836: N49 G1 E124.00 F1200
    Send:8:47:39.836: N50 M82
    Send:8:47:42.655: N51 G92 E24.0000
    Send:8:47:42.655: N52 G1 E174.00 F1200
    Send:8:47:42.655: N53 M82
    Send:8:47:48.282: N54 G92 E24.0000
    Send:8:47:48.282: N55 G1 E224.00 F1200
    Send:8:47:48.282: N56 M82
    Send:8:47:56.703: N57 G92 E24.0000
    Send:8:47:56.703: N58 G1 E274.00 F1200
    Send:8:47:56.703: N59 M82
    Send:8:48:08.038: N60 G92 E24.0000
    Send:8:48:08.038: N61 G1 E324.00 F1200
    Send:8:48:08.038: @updatePrinterState
    Send:8:48:08.040: @moveRel E50.0000 F2
    Send:8:48:08.040: N62 M82
    Send:8:48:22.169: N63 G92 E324.0000
    Send:8:48:22.169: N64 G1 E374.00 F120
    Send:8:48:22.169: @updatePrinterState

    As you see it totals to 350mm which is correct.

    What do you get as output if you do? If you have a custom insert script it may add extra gcode not considered by our moves. Actually changed gcode to prevent wrong extrusions as you see by setting mode and E position we thing should have before sending the move now.
  • Change Filament (using 7'' touchscreen interface)

    set 100mm Fast and 0mm Slow

    the Output is 150mm filament

    from integrated g-code console:

    Send:21:51:50.855: N17 M104 S200 T0
    Recv:21:51:50.870: ok
    Send:21:51:50.871: N18 M104 S200 T0
    Recv:21:51:50.887: ok
    Send:21:51:52.310: @moveRel E100.0000 F25
    Send:21:51:52.310: N19 M82
    Recv:21:51:52.324: ok
    Send:21:51:52.325: N20 G92 E0.0000
    Recv:21:51:52.341: X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
    Recv:21:51:52.341: ok
    Send:21:51:52.341: N21 G1 E50.00 F1500
    Recv:21:51:52.357: ok
    Send:21:51:52.357: N22 M82
    Recv:21:51:52.372: ok
    Send:21:51:52.372: N23 G92 E0.0000
    Recv:21:51:52.388: X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
    Recv:21:51:52.389: ok
    Send:21:51:52.389: N24 G1 E100.00 F1500
    Recv:21:51:52.405: ok
    Send:21:51:52.405: @updatePrinterState
    Send:21:51:52.405: @moveRel E0.0000 F2
    Send:21:51:52.405: N25 M82
    Recv:21:51:52.421: ok
    Send:21:51:52.421: N26 G92 E100.0000
    Recv:21:51:52.452: X:0.00 Y:0.00 Z:0.00 E:100.00 Count X:0 Y:0 Z:0
    Recv:21:51:52.452: ok
    Send:21:51:52.452: N27 G1 E100.00 F120
    Recv:21:51:52.468: ok
    Send:21:51:52.468: @updatePrinterState

    repeat changing setting to 200mm Fast and 0mm Slow

    the Output is 500mm filament!!!!!!???

    from integrate g-code console:

    Send:21:55:50.836: N34 M104 S200 T0
    Recv:21:55:50.854: ok
    Send:21:55:50.854: N35 M104 S200 T0
    Recv:21:55:50.870: ok
    Send:21:55:53.912: @moveRel E200.0000 F25
    Send:21:55:53.913: N36 M82
    Recv:21:55:53.923: ok
    Send:21:55:53.923: N37 G92 E100.0000
    Recv:21:55:53.940: X:0.00 Y:0.00 Z:0.00 E:100.00 Count X:0 Y:0 Z:0
    Recv:21:55:53.940: ok
    Send:21:55:53.940: N38 G1 E150.00 F1500
    Recv:21:55:53.954: ok
    Send:21:55:53.954: N39 M82
    Recv:21:55:53.970: ok
    Send:21:55:53.970: N40 G92 E100.0000
    Recv:21:55:53.987: X:0.00 Y:0.00 Z:0.00 E:100.00 Count X:0 Y:0 Z:0
    Recv:21:55:53.987: ok
    Send:21:55:53.987: N41 G1 E200.00 F1500
    Recv:21:55:54.002: ok
    Send:21:55:54.002: N42 M82
    Recv:21:55:54.018: ok
    Send:21:55:54.018: N43 G92 E100.0000
    Recv:21:55:54.035: X:0.00 Y:0.00 Z:0.00 E:100.00 Count X:0 Y:0 Z:0
    Recv:21:55:54.035: ok
    Send:21:55:54.035: N44 G1 E250.00 F1500
    Recv:21:55:54.050: ok
    Send:21:55:54.050: N45 M82
    Recv:21:55:54.066: ok
    Send:21:55:54.066: N46 G92 E100.0000
    Recv:21:55:54.083: X:0.00 Y:0.00 Z:0.00 E:100.00 Count X:0 Y:0 Z:0
    Recv:21:55:54.083: ok
    Send:21:55:54.083: N47 G1 E300.00 F1500
    Recv:21:55:54.099: ok
    Send:21:55:54.099: @updatePrinterState
    Send:21:55:54.099: @moveRel E0.0000 F2
    Send:21:55:54.100: N48 M82
    Recv:21:55:54.114: ok
    Send:21:55:54.115: N49 G92 E300.0000
    Recv:21:55:54.131: X:0.00 Y:0.00 Z:0.00 E:300.00 Count X:0 Y:0 Z:0
    Recv:21:55:54.131: ok
    Send:21:55:54.131: N50 G1 E300.00 F120
    Recv:21:55:54.147: ok
    Send:21:55:54.147: @updatePrinterState


    send the command from the console integrated in Repetier-Server:

    Send:22:00:32.920: N53 G92 E0
    Recv:22:00:32.941: X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
    Recv:22:00:32.941: ok
    Send:22:00:52.048: N54 G1 E100 F200
    Recv:22:00:52.058: ok

    the output is 100mm filament OK!!!

    Send:22:02:13.493: N55 G92 E0
    Recv:22:02:13.515: X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
    Recv:22:02:13.515: ok
    Send:22:02:22.035: N56 G1 E200 F200
    Recv:22:02:22.050: ok

    the output is 200mm filament  OK!!!


    usb direct connection to printer

    send command
    G92 E0
    G1 E100 F200 

    Output: exactly 100mm filament

    send command
    G92 E0
    G1 E200 F200

    Output: exactly 200mm filament

    the printer works fine!

  • Ok found the reason. The initalzing G92 does not get updated between moves here making each successive move add 50 more mm due to being in absolute E mode. Will fix it for 1.4.9 coming probably next week.

    Thanks for the help.
Sign In or Register to comment.