Print pauses and restarts.

Hi everybody, 
i'm using repetier server 0.60.4 running on a raspberry pi with my K8200/3DRag and sometimes (with a completely random frequency) the print stops for about 30 seconds and restarts (sometimes it doesn't restart at all).
Here's the part of the log file where the problem happens:

<  9:00:31.500: N15150 G1 X86.150 Y78.521 E979.10985
>  9:00:31.502: ok
<  9:00:31.521: N15151 G1 X86.866 Y78.943 E979.13222
<  9:00:31.524: N15152 M105
>  9:00:31.523: ok
<  9:00:31.542: N15153 G1 X87.594 Y79.343 E979.15457
>  9:00:31.558: ok
>  9:00:31.565: 65.0 @:128 B@:128
>  9:00:31.571: B:64.3 /ok
>  9:00:31.580: 0 @:128 B@:128
>  9:00:31.585: ok
>  9:01:03.641: Warning: Communication timeout - resetting communication buffer.
<  9:01:03.643: N15154 M105
<  9:01:03.653: N15155 G1 X88.335 Y79.719 E979.17692
>  9:01:03.656: ok T:172.0 /175.0 B:65.2 /65.0 @:128 B@:128
<  9:01:03.666: N15156 G1 X89.086 Y80.072 E979.19925
>  9:01:03.671: ok
<  9:01:03.676: N15157 G1 X89.849 Y80.404 E979.22164
>  9:01:03.679: ok
<  9:01:03.685: N15158 G1 X90.621 Y80.710 E979.24399
>  9:01:03.687: ok
<  9:01:03.693: N15159 G1 X91.402 Y80.992 E979.26633
>  9:01:03.696: ok
<  9:01:03.705: N15160 G1 X92.191 Y81.250 E979.28866
>  9:01:03.712: ok
<  9:01:03.718: N15161 G1 X92.989 Y81.483 E979.31103

I tried on different hardware (raspberry pi, banana pro) but the problem is still here.
What can i do?

thanks for the support.


  • The problem is exactly what you see in log. The answers are incomplete so server does not know the command was executed. Then as a last resort the timeout catches the problem and continues sending the job. So best solution is making communication error free.

    Other things to reduce effects:
    - Make sure to use the largest possible buffer size. If you used latest Arduino IDE it is 127 byte.
    - Use firmware which sends line number with ok, this can catch 1-2 missed ok without any delay. From your log I see you are using Marlin. Latest development version of Marlin (not sure if it is also in latest stable) also has this feature if you do not want to switch to repetier-firmware.
    - Try different baud rate. Sometimes one baud rate causes more errors then others. One of 115200 and 250000 should do.
  • Thank you for the answer, i tried the latest marlin version (i suppose) but i can't see the line number confirmation.
    Is there something i have to activate?

    Thank you
  • I only saw it on the development tree so far and didn't need to activate it if I remember right.
  • Changing the usb cable with a shorter one with a ferrite bead seems to have resolved (crossing fingers) all the problems.

    Thanks for the support.
Sign In or Register to comment.