Raspberry Pi camera Module 3 doesn't work

Hi all, I bought the new Wide Camera Module 3 for my Pi4 and it doesn't work.
any solutions for my Problem yet or does anyone have the same troubles?
I see the in the Pulldown menu at Printer Settings but I can't select it...

Thanks in advance for your support.


  • Not selectable means the device was seen but mjpg_streamer is currently not running.
    You can restart it and check /var/log/syslog why it stopped again.

    Which image are you using? Lately the bullseye version changed libcamera version so updating linux breaks pi camera. So with every image we provide a version that works with the current version.

    One solution is to call 
    sudo raspi-config
    and in camera select legacy system. This switches to old graphic driver with old webcam solution and has much less load for cpu since pi cam does then jpg encoding. Might also help in your case. Not sure if new system supports all webcams old solution supported.
  • Thanks for your answer, I flashed the SD, today, with the image from your HP., completely new. I tried some different ways but the new RasPi 3 Cam did not work. I tried the old system too, Repetier-->Terminal-->Login-->, .... The camera is in the pull down menu where you can select the different cameras but if I connect the new Camera then it's "greyed" out and not selectable anymore. now I switched back to the old camera and everything is fine. Maybe it works with the next future Updates.

  • That is not really in our hands as this is linux driver and mjpg_streamer which is 3rd party software we do not develop. But we include updates so maybe.

    Device appears because a cam in general is detected. So I also assume that streamer starts. But only in /var/log/syslog you can see why it stopped after starting. It also might just be incompatible resolution/framerate or something serious because it is a unknown model that was not implemented in the driver. My original pi cam at least works.
  • Both Cameras are original Cams. The older V2 works, the new V3 does not work. If I have time on weekend I connect the new V3 and copy/paste the syslog if you are interested. Thank you for your support, Claus
  • Yes, would be great. My pi cam is older guess V2.
Sign In or Register to comment.