Repetier Server on raspberry failed to start

Yesterday i've shutdown the it doesn't start.
I've tried to restart manually but here is the systemctl status log:
RepetierServer.service - Repetier-Server 3D Printer Server
     Loaded: loaded (/lib/systemd/system/RepetierServer.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Wed 2023-01-18 21:25:45 GMT; 8s ago
    Process: 1733 ExecStartPre=/bin/mkdir -p /var/lib/Repetier-Server (code=exited, status=0/SUCCESS)
    Process: 1735 ExecStartPre=/bin/chown -R repetierserver /var/lib/Repetier-Server (code=exited, status=0/SUCCESS)
    Process: 1739 ExecStart=/usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml --daemon (code=exited, status=203/EXEC)
        CPU: 31ms

Jan 18 21:25:45 3Dprinter systemd[1]: RepetierServer.service: Scheduled restart job, restart counter is at 5.
Jan 18 21:25:45 3Dprinter systemd[1]: Stopped Repetier-Server 3D Printer Server.
Jan 18 21:25:45 3Dprinter systemd[1]: RepetierServer.service: Start request repeated too quickly.
Jan 18 21:25:45 3Dprinter systemd[1]: RepetierServer.service: Failed with result 'exit-code'.
Jan 18 21:25:45 3Dprinter systemd[1]: Failed to start Repetier-Server 3D Printer Server.
Thank you for the help....


  • That does only show that it was killed after 8s. Better would be output of manual start in ssh terminal:

    export LC_ALL=C
    sudo -u repetierserver /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml

    Also what version and printer firmware are you using?

  • I've tried these commands but doesn't create the xml file....this evening I'll retry.
  • /usr/local/Repetier-Server/etc/RepetierServer.xml ist part of the installation and always exists! But sometimes a file is corrupt and crashes server when it tries to read it. That is something I'm guessing here.
  • Now i'm trying the above command but nothing 
    there isn't files...
  • May you tell me where i can find, if exist, a config file with my printer personal settings? i can save it, reinstall raspberry image and past the configuration....thank you 
  • ls -l /usr/local/Repetier-Server/etc
    total 4
    -rw-r--r-- 1 root root 1199 Jan  6 07:36 RepetierServer.xml

    If that is empty as you say, you just need to reinstall server. On revent images you just use this command:

    Your settings will be kept with the update. Settinsg are all in /var/lib/Repetier-Server while in /usr/local/Repetier-Server our software files reside.

    But since files do noormally not disappear that is strange. Except maybe when pi had issues during update. In any other case I'd make a backup of settings folder and make a fresh image. You never know what is wrong when files start to disappear and new image is often best solution.
  • Hmmm....output when i try to use your command "installLatestServer Le" <span>:smile:</span>

    : error processing archive RepetierServerLatest.deb (--install):
     unable to make backup link of './usr/local/Repetier-Server/bin/createFirmware' before installing new version: Operation not permitted
    dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
    Install Repetier-Server
    Created symlink /etc/systemd/system/ → /lib/systemd/system/RepetierServer.service.
    Job for RepetierServer.service failed because the control process exited with error code.
    See "systemctl status RepetierServer.service" and "journalctl -xe" for details.
    Errors were encountered while processing:

  • I will reinstall the raspberry image. I can't go to the register menu to deactivate the license on this install...the new one on the same machine, will it decrease the available licenses?
  • Yes, looks like something is in bad state. Probaby the same that went wrong with update.

    If you copy /var/lib/Repetier-Server folder back license is activated again. Just wtach out that server is not running when copying them back and you have no permission evenually as you work as user pi. When server is stoppen you can change owner for copy. On restart server will change it back to repetierserver.
    sudo service RepetierServer stop
    sudo chown -R pi /var/lib/Repetier-Server

    Now copy to/from folder with scp software like winscp or any other tool you like.
  • edited February 11
    ...sorry...solved...sorry again
Sign In or Register to comment.