Duet Filamentsensor abfrage

Moin,

Folgendes Setup:
Duet Board (RRF3.4) per usb mit Repetier-Server (1.4.6)

config.g:
; Heaters
M308 S0 P"temp0" Y"thermistor" T100000 B4138                ; configure sensor 0 as thermistor on pin temp0
M950 H0 C"out0" T0                                                         ; create bed heater output on out0 and map it to sensor 0
M307 H0 R0.150 K0.067:0.000 D40.82 E1.35 S1.00             ; enable bang-bang mode for the bed heater and set PWM limit B1 = BangBangMode on
M140 H0                                                                         ; map heated bed to heater 0
M143 H0 S100                                                                 ; set temperature limit for heater 0 to 100C
M308 S1 P"temp1" Y"thermistor" T100000 B4138                ; configure sensor 1 as thermistor on pin temp1
M950 H1 C"out1" T1                                                         ; create nozzle heater output on out1 and map it to sensor 1
M307 H1 R2.430 K0.560:0.000 D5.50 E1.35 S1.00 B0 V0.0   ; disable bang-bang mode for heater  and set PWM limit
M143 H1 S280                                                                 ; set temperature limit for heater 1 to 280C

; Custom settings
M591 D0 P1 C"io4.in" S1                            ; Filament run-out sensor / P-> Switchtype 1=high 2=low / S-> 0=Off 1=On

Situation:
Filament Runout wird von DWC erkannt und während einem SD-Druck ausgeführt. Auch ein M591 D0 zeigt, den richtigen zustand vom Filament an.
Bei einem Druck per Repetier wird weitergedruckt.

In der Konsole kommt flogende Meldung:
Recv:15:53:41.518: - Event notification -
Recv:15:53:41.519: Filament error on extruder 0: noFilament

Also habe ich diese bei RepetierServer G-Code als Ereigniss angelegt als "Filament error on extruder 0: noFilament"

Problem:
Das Ereignis wird ausgeführt, jedoch im Sekundentakt egal ob Filament eingelegt ist oder nicht. Darauf hin habe ich ACK aktiviert und gesehen, dass egal welcher zustand der Filament Sensor hat dauerhaft ein " "msgBox":{"msg":"Filament error on extruder 0: noFilament", " gesendet wird.

Frage:
Wie löse ich das Problem? :-D 

Vielen Dank schon mal im voraus für eure Hilfe :-)

Comments

  • Ok das Problem ist leicht zu lösen. Die Meldung die du willst fängt mit dem Satz an und muss ich nicht enthalten. Fange also deine Regel mit ^ and um anzuzeigen das die Antwort damit anfangen muß. Damit wird deie Mledung in msg ignoriert. Also
    ^Filament error on extruder 0: noFilament

    als Regel. Das event wird ja anscheinend nur einmal erzeugt. Jetzt muss ich noch gucken wegen der msg box. Dialoge über dcs werden jetzt gezeigt, vielleicht finde ich hie rauch eine Lösung die messages im interface zu Zeigen, ist ja der Sinn der msg meldung. Und die Meldung werde ich dann vermutlich als Filamentwechsel aufforderung ansetzen was danna uch gleich eine Pause erzeugt.
  • Ok, ab der nächsten Version erkennt er das automatisch, wechselt in Filemantwechsel und zeigt ein popup mit der Meldung an weil er die duet Dialogboxen jetzt erkennt.
  • Ihr seid einfach nur geil/spitze/super/genial ... sucht euch was aus :-D
Sign In or Register to comment.