Z axis not homing before print start

Hi! Being my first post I apologize if I put it in the wrong category. But since this happens only when slicing with Cura I presume this would be the right place.

My setup is as follows:
Repetier-Host 1.5.4 (x64)
Prusa i3 with Marlin
Cura_SteamEngine 15.01

I use the default startup code (see below). The problem I have is that after homing (G28) there's a G1 Z15 command that lifts the extruder but it's not returned to 0 before the print starts. I.e. it's extruding in mid air. Tried adding a G1 Z0 to the end of the start up but didn't help.

Thank you for reading.

; Default start code
G28 ; Home extruder
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}


  • For me it always worked, so my first question is what is the exact result you get including the first skirt print moves. Your example stops at 15mm which is what you said does work. The first generated travel moves should go to first layer height and I expect that code to be there, but we need to see it to say.
Sign In or Register to comment.