no audio at @sound command

What is the correct command type for sending an audible alert to Repeater from the printer controller firmware? I've tried various messages with no luck getting Repetier to sound off. The preferences setting in Repetier is turned ON with a sound selected (played when tested). The documentation says the command is "@sound", but this isn't working for me. Is anyone else using this command and getting it to work? 


  • I just tried after connecting by sending @sound over manual control and a sound appeared. Only disabled sound in configuration should prevent it. Note that in config you can play it also if it is disabled, so make sure it is checked.
  • I'm experiencing the same trouble.  I put @sound in my gcode file at the beginning of a layer to warn me that a bridging layer is coming so I can watch it.  That @sound never happens even though it is placed at 5 different points in the file.  However, I put another @sound right before a M109 SXXX to set the extruder to a new temperature.  The printer stops to wait for the extruder to heat up to the new temperature and after about a 5 second delay, the sound goes off.

    For the other @sound that doesn't work, I've tried adding extra commands around it and even multiple @sounds like this:
    @info Before Sound
    @info After Sound

    I see the info messages, but still no sound goes off.

    This is using the latest stable Marlin software with Repetier Host 1.5.4 on Windows.
Sign In or Register to comment.