Connection Error

I'm pulling out my hair in frustration.

So I have had my RepRap printer (Arduino 2560 controller)  for over a year and used it successfully on Repetier Host 1.0. * (something) running on Windows 8.1.

I then walked away for a few months. So, I come back to do some printing and first thing I see is Repetier has an update 1.5.4. So I download and things are good. Until I try to connection...

The standard message that access is denied to COM4. (actually a USB port).
1. I check my device manager, and yes, the computer sees the MEGA 2560 connected to COM 4.
2. i load up the Arduino IDE. Nope it cant talk to any Arduino boards either. Ahh....the ol' Windows 8 unsigned drivers problem!!!
3. I go thru all the steps to re-install the drivers for Arduino.
4. Go back to the Arduino IDE and yes, it can see the boards now.
5. Go back to Repetier. Nope, still can't connect. Maybe I forgot the baud rate setting?
6. I painstakingly try every Baud rate 9600- 128000. Still can't connect.

Any more suggestions?


  • I had the same problem.  Upgraded to 1.5.4, access denied, Grrr.... After Uninstalling/Reinstalling multiple times, I stumbled onto the semi fix.
    Apparently, Repetier SERVER is running, go to program files and expand to Repetier-Server>Stop Server.  Then start Repetier Host and try to connect.  It worked for me, hope this helps.
  • You have to decide if you want to print over server or host. At start server is not configured so it will not block anything, but one activated it will autoconnect and thus block the port. In the server you can disable and enable printer to free the port. If the server connects you should simply use the server connector in the host to connect. Then it connects through the server and you can use it like you did before.

    You should also try 250000 baud which also often used apart from 115200 baud.
  • Yup, that was it. Simply went into "Server" and stopped local server. Next attempt. Boom!!! Successful. Thanks folks!
  • Oh, maybe I spoke too soon. I got connection, but printer isn't responding to any manual controls? Communication setting?
  • Yes, if you see x commands waiting yout baud rate is most likely wrong but the port was free.
  • So yes, I walked away for a bit (again), but I'm back after building up enough enthusiasm to tackle the problem some more.

    Started up Repetier, plugged everything in, turned everything on and hit "connect". Same error as previously noted. That's ok, 
    That's ok. We have a solution. Turn off the server. And that's what I did and "Shazaam" the connection was good.

    This is as far as I got last time. As no manual commands appear to be going thru, I suspected the baud rate was just set wrong (also as suggested).

    1. Open printer settings
    2. Select a baud rate
    3. Hit ok (to close printer settings window"
    4. On manual control tab, attempt to move the extruder a few millimeters.
    5. Repetier responds "5 commands waiting" (or more)

    Go back to Step 1 and repeat.

    Did this while scrolling thru all the baud rates. Never got a response once. 

    <insert heavy sigh here>
  • When you check this do you have log visible and ack enabled? This greatly helps to see if printer starts to respond.

    Since you have confiugred server to use the printer (that is why you couldn't connect) it would be an idea to test if the server could connect successfully. If yes, select the server connector in printer setting for printing and print through the server. That is the reason we offer the server anyway. To allow printing without the host needing to be running and allowing to print bigger files as possible with the host.
  • I just built my Flsun i3 DIY Kit 3D printer. Trying to connect to it

    I am running Windows 10. I have the same difficulty connecting. I have stopped Server but still will not connect.

    Device manager list the Usb Printer connection.

    Help please.....

  • So you are already seing the extra com port appear when connecting printer and did use that com port in host with baud rate set in firmware?
  • Repetier said:
    So you are already seing the extra com port appear when connecting printer and did use that com port in host with baud rate set in firmware?

    Fixed the problem! I thought it was Windows 10, so tried on another PC...same problem. It kept saying Server was connected.  I thought maybe I had downloaded the wrong programme or not selected the correct options when installing, so went to Uninstall. I found that Repetier Server had been installed and Repetier Host. So just uninstalled Repetier Server and Connect worked!
  • Type "Services" in start/Windows and then search for Repetier-Server, right click it and then select stop.
  • I had the same issue. Check if any other software using the port. In my case Ultmaker Cura was using it, so repetier app was unable to connect
Sign In or Register to comment.