Nach Druck herunterfahren

Guten Tag,

wenn ich einen Druck gestartet habe und den schiebe Regler (Nach Druck Herunterfahren) aktiviere passiert nach dem Druck nichts. Der Pi bleibt an. Ich habe die aktuelle Version installiert. Läuft auf einem Pi. Gibt es irgendwo Logfiles oder configs die ich nachschauen oder anpassen muss da diese Funktion klappt? Beim Einrichten vom PI habe ich auf den default user "pi" verzichtet und einen eigenen gewählt. Dieser hat ebenfalls "Sudo" rechte. 

Wenn ich nach dem ein Druck beendet ist auf dem Hauptbildschirm "Herunterfahren" antippe passiert das was ich möchte, der PI geht aus. Viele Danke. 

voidcore

Comments

  • Das ist erst mal korrekt so. Gedacht ist hier eigentlich drucker herunterfahren. Was passier ist das wenn die Funktion aktiviert ist nach dem Druck das Skript in Konfig->G-Codes->Ereignisabhängig->Drucker herunterfahren ausgeführt wird, das normal leer ist da wir nicht wissen wie man die Drucker herunterfährt. Bei leerem Skript sendet er G81 was der offizielle G-Code zum ausschalten eines Druckers ist. Mache können das mit G-Code, manche haben schaltbare steckdosen (wobei man den pi ja nicht einfach ausschalten darf ohne vorher herunterzufahren). Wenn du da

    @execute shutdown

    einfügst sollte er das herunterfahren des Pi aktivieren.
  • edited November 17
    Ok, wenn ich mehr als 1 Drucker nutze sollte ich den Schalter auf der gui nur da aktivieren wo er am längsten brauch. Danke für den Hinweis. Ich werde es testen. 

    Das mit dem ausschalten ist genau so geplant. Wenn der Drucker den pi ausschaltet habe ich noch 15Watt (rein der Drucker, beleuchtung) und wenn die 15 Watt länger als 5min Anliegen will ich dann die Steckdose vom Drucker inkl. pi ausschalten. 
  • Es hat funktioniert, leider war der shutdown schneller als PushOver noch was schicken konnte. 
    Ich teste mal folgendes, so das vielleicht noch PushOver durch geht. Falls ich damit falsch liege bitte ein Hinweis wie man es noch lösen könnte. 

    @execute shutdown +2 


  • voidcore said:
    Es hat funktioniert, leider war der shutdown schneller als PushOver noch was schicken konnte. 
    Ich teste mal folgendes, so das vielleicht noch PushOver durch geht. Falls ich damit falsch liege bitte ein Hinweis wie man es noch lösen könnte. 

    @execute shutdown +2 


    Hat gepasst! Danke!
  • Wundert mich da zumindest in der default extcommands.xml der Befehl ohne Parameter steht und da explizit -h now steht. Oder hast du es dort auch geändert?
  • Nein, ich habe wirklich nur den c-gode eingetragen. Wenn @execute das Äquivalent zu /bin/bash ist dann würde es passen. Ich habe das aus folgender Hilfe:

    https://linuxiac.com/linux-shutdown-command/
    Let’s now schedule a system shutdown for 30 minutes from now:

    Das +h muss man evtl. nicht angeben wenn man nur die Zeit anhängt. 
Sign In or Register to comment.