Refresh caché of edited files

edited November 17 in Bug Reports
When you edit a Gcode in the library and save.

Then open it and you can see the original unedited file.
I tried F5 and dont solve the problem.
tried F5+Alt and dont solve the problem.

Change browser solve the problem.

Maybe you can sneak peak this.

Comments

  • With library you mean g-codes in projects?

    I tried it and it worked as it should. May be depend on some browser settings or proxys in between. I noticed there were no cache-control statements, so it is not exactly forbidden to cache, also date of file changed. So I had added a cache control block for next version to hopefully prevent this issue.
  • edited November 18
    The problem seems to ocurr when I edit some files and then I try to re-edit recently edited files.

    Same file, updated and not updated in Firefox Vs Repetier Server Monitor.



  • Firefox is the key to repeat it. With firefox it also happened with old version and current dev version with no-cache does not have it anymore - at least repeating same test. Only if it is still in cache when you retry it might happen again. SO after clear cache in 1.4.4 it should not happen any more.
Sign In or Register to comment.