Error - Repetier-Server currently not avaliable

Hi Guys, 
A few days ago my instance of rep server running on a Rasp pi stopped & started displaying an error on the web browser URL. 

I have tried to troubleshoot the issue with no success , so I decided to just reinstall onto the SD, at first this worked for a few hours & then the same error appeared. 

I then tried the SD on another raspberry pi to see if it was a hardware issue, but the same error is still present. 

If I connect a monitor to the pi, the splash screens go through fast & then i get a blank screen with no ability to use the command line. 

I can connect via SSH , but not sure what to try next. 

Any idea what could be causing this ? & how I can try to resolve ?

Repetier-Server currently not avaliable

It seems that Repetier-Server is currently not running. Retrying in 27 seconds.

If it does not restart in a reasonable time, the service might be stopped. You can restart the service in a terminal windows sending the command:

sudo service RepetierServer restart

If it fails to start as a service start it manually. You will see the logging on the terminal and will help you hopefully to identify the problem.

export LC_ALL=C 

sudo -u repetierserver /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xmlerServer.xml


  • This comes from nginx that acts as proxy to the real server. You see this normally if server is not running. So if you can login vis ssh try what it suggest and run:
    export LC_ALL=C 

    sudo -u repetierserver /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xmlerServer.xml

    that starts server again but you will see all error messages in console running ssh. That hopefully shows until which stage it can start and what is than causing the crash. A typical reason is a bad file in /var/lib/Reepetier-Server/database folder. If you see the last line probably a starting xyz message it is likely that the config file needed for this is defect. You can try renaming the file in database and restart. It will be recreated (with empty default content). If it starts that was the defect file and you loos what was stored in that, e.g. ig it was user.sql you loose user list. You can also just rename database fodler to test if it is any file in that and copy it back later to test for more details.

  • Thanks, looks like I must have messed up my timelapse settings & my last print generated 15gb of files filing up the SD card. Not sure why the fresh install also failed soon after, but it working now so thats the main thing. 
  • Yes, timelapse can really fill disk quickly, especially if you do not select to delete the images after successful convertion to a movie or if you have frequent images taken on a long print. On home screen you see free disk space on used drive.
Sign In or Register to comment.