[1.4.2] List of gcode files shown empty after update

edited November 14 in Bug Reports
Just updated from 1.3.0 to 1.4.2.
Now the list of uploaded gcode files is always shown as empty (even if I switch to the "all" group).
When uploading new files I see no error in the logfiles - just no entry in the list of gcode files.
I already tries to delete all gcode files and even removed all groups but Default, still newly uploaded files aren't shown, the list stays empty.
Thus the only way to start a print atm. is via direct print - this works.

Comments

  • P.S.: The list is shown empty both in the internal Touch screen of the printer as well as in the web frontend from pc or smartphone.
  • Did you already try restarting computer?
    Which OS is the server running on?
    This is no usual behaviour so the question is, if ther eis some defect on filesystem or something prevents accessing the model folder in data storage/printer/(slug)/model folder. Did you check already if the folders are empty. The logfile to check would be server.log. You also should update to 1.4.3 in case a bug fixed in 1.4.3 is causing this.
  • edited November 15
    Hi,
    sure, I have rebooted, even switched the printer off and on again.
    Will have to contact the printer manufacturer which exact OS they use, think it is some kind of Linux (and/or check whether I have ssh access to the shell - currently the integrated Raspberry Pi directly boots into the Repetier Server UI). Have used the update feature in Repetier server which pulled the then-latest version yesterday. Am currently not at home, think it was 1.4.2. If 1.4.3 is available since today I can do the update. How would I install another version than the one that is pulled by the auto-updater?
  • Update: 1.4.3 is installed, indeed, sorry for the wrong info! Am in contact with the manufacturer regarding further OS details and/or ssh access.
  • Update 2: Have shell access now.

    Installed OS: Raspbian GNU/Linux 10 (buster)

    Found some model files on the drive (the *.g files seem to contain gcode):

    pi@ONEPRO:/var/lib/Repetier-Server/printer/iFactory3D__One_Pro/models $ ls
    00000001_PRO_xyzCalibration_cube.g        00000010_3DBenchy.g
    00000001_PRO_xyzCalibration_cube.gin      00000010_3DBenchy.gin
    00000001_PRO_xyzCalibration_cube.layer    00000010_3DBenchy.layer
    00000001_PRO_xyzCalibration_cube.linfo    00000010_3DBenchy.linfo
    00000001_PRO_xyzCalibration_cube_l.png    00000010_3DBenchy_l.png
    00000001_PRO_xyzCalibration_cube_m.png    00000010_3DBenchy_m.png
    00000001_PRO_xyzCalibration_cube_s.png    00000010_3DBenchy_s.png
    00000002_3DBenchy.g                       00000011_3DBenchy.g
    00000002_3DBenchy.gin                     00000011_3DBenchy.gin
    00000002_3DBenchy.layer                   00000011_3DBenchy.layer
    00000002_3DBenchy.linfo                   00000011_3DBenchy.linfo
    00000002_3DBenchy_l.png                   00000011_3DBenchy_l.png
    00000002_3DBenchy_m.png                   00000011_3DBenchy_m.png
    00000002_3DBenchy_s.png                   00000011_3DBenchy_s.png
    ...

    There seems to be enough space available:

    pi@ONEPRO:/ $ sudo df
    Filesystem     1K-blocks    Used Available Use% Mounted on
    /dev/root        7346376 3282980   4045120  45% /
    devtmpfs          767300       0    767300   0% /dev
    tmpfs             932164    7944    924220   1% /dev/shm
    tmpfs             932164    8672    923492   1% /run
    tmpfs               5120       4      5116   1% /run/lock
    tmpfs             932164       0    932164   0% /sys/fs/cgroup
    /dev/mmcblk0p1    258095   72641    185454  29% /boot
    /dev/sda1       30281600   17744  30263856   1% /media/flash
    tmpfs             186432       0    186432   0% /run/user/1000

    Found this in the system.log:
    2022-11-15 12:23:02: Error reading model description /var/lib/Repetier-Server/printer/iFactory3D__One_Pro/models/00000010_3DBenchy.gin:Syntax error
    2022-11-15 12:23:02: Error reading model description /var/lib/Repetier-Server/printer/iFactory3D__One_Pro/models/00000010_3DBenchy.gin:Syntax error
    2022-11-15 12:23:03: Time analysing /var/lib/Repetier-Server/printer/iFactory3D__One_Pro/models/00000010_3DBenchy.g:1268587 us
    2022-11-15 12:23:03: Updating info for /var/lib/Repetier-Server/printer/iFactory3D__One_Pro/models/00000011_3DBenchy.g printer iFactory3D__One_Pro
    2022-11-15 12:23:03: Error reading model description /var/lib/Repetier-Server/printer/iFactory3D__One_Pro/models/00000011_3DBenchy.gin:Syntax error
    ...

    Here the exemplary content of /var/lib/Repetier-Server/printer/iFactory3D__One_Pro/models/00000010_3DBenchy.gin:

    analysed: 1
    analysisTime: 1.261775
    created: 1668440037000
    extruder0: 4612.1337890625
    extruder1: 0
    extruder10: 0
    extruder11: 0
    extruder12: 0
    extruder13: 0
    extruder14: 0
    extruder15: 0
    extruder16: 0
    extruder17: 0
    extruder18: 0
    extruder19: 0
    extruder2: 0
    extruder20: 0
    extruder21: 0
    extruder22: 0
    extruder23: 0
    extruder24: 0
    extruder25: 0
    extruder26: 0
    extruder27: 0
    extruder28: 0
    extruder29: 0
    extruder3: 0
    extruder30: 0
    extruder31: 0
    extruder4: 0
    extruder5: 0
    extruder6: 0
    extruder7: 0
    extruder8: 0
    extruder9: 0
    extruderVolume0: 11093.481809773568
    extruderVolume1: 0
    extruderVolume10: 0
    extruderVolume11: 0
    extruderVolume12: 0
    extruderVolume13: 0
    extruderVolume14: 0
    extruderVolume15: 0
    extruderVolume16: 0
    extruderVolume17: 0
    extruderVolume18: 0
    extruderVolume19: 0
    extruderVolume2: 0
    extruderVolume20: 0
    extruderVolume21: 0
    extruderVolume22: 0
    extruderVolume23: 0
    extruderVolume24: 0
    extruderVolume25: 0
    extruderVolume26: 0
    extruderVolume27: 0
    extruderVolume28: 0
    extruderVolume29: 0
    extruderVolume3: 0
    extruderVolume30: 0
    extruderVolume31: 0
    extruderVolume4: 0
    extruderVolume5: 0
    extruderVolume6: 0
    extruderVolume7: 0
    extruderVolume8: 0
    extruderVolume9: 0
    fileSize: 0
    gcodePatch: {}
    lastPrintingTime: 0
    layer: 291
    lines: 184497
    material0:
    material1:
    material10:
    material11:
    material12:
    material13:
    material14:
    material15:
    material16:
    material17:
    material18:
    material19:
    material2:
    material20:
    material21:
    material22:
    material23:
    material24:
    material25:
    material26:
    material27:
    material28:
    material29:
    material3:
    material30:
    material31:
    material4:
    material5:
    material6:
    material7:
    material8:
    material9:
    notes:
    printed: 0
    printingTime: 5336.25892638786
    radius: 159.8802490234375
    radiusMove: 0
    repeat: 1
    slicer: ideaMaker
    totalFilament: 4612.1337890625
    totalVolume: 11093.481809773568
    version: 1
    xMax: 155.2760009765625
    xMaxMove: inf
    xMaxView: 155.2760009765625
    xMin: 124.7229995727539
    xMinMove: 20
    xMinView: 124.7229995727539
    yMax: 67.65699768066406
    yMaxMove: inf
    yMaxView: 67.65699768066406
    yMin: 0.22499999403953552
    yMinMove: 0
    yMinView: 0.22499999403953552
    zMax: 82.47000122070312
    zMin: 0
  • Ok problem 1 is
    xMaxMove: inf

    When it reads inf it gets syntax error, becaus eit is no number. I tested this actually and I got the error message you have and it was recomputed (the gin file) and then had correct value. If you still have inf it might be something in your brnchy .g file causing this. Would be great if you can offer that slice for download so I can test if it causes the values to be computed as inf somehow.

    None the less it would return info with missing/wrong default values but not stop loading.

    Now the g-codes are associated to a group in /var/lib/Repetier-Server/printer/iFactory3D__One_Pro/modelGroups.json file. Check with
    cat /var/lib/Repetier-Server/printer/iFactory3D__One_Pro/modelGroups.json
    if it still correct. Has actually same format as old server so doe snot get updated. Anyhow, please also check if you see the models when you select group "All" instead of default or what ever you had active. This should show all g-codes regardless of which group it is associated. 
  • edited November 15
    Sure, here the Benchy gcode (sliced with IdeaMaker):
    Group "All" as well as group "Default" are both shown empty in the UI.

    Here the modelGroups.json (it is in the subfolder data now):

    pi@ONEPRO:/var/lib/Repetier-Server/printer/iFactory3D__One_Pro $ ls -a
    .  ..  data  jobs  last_prints  logs  models  Plates  timelapse
    pi@ONEPRO:/var/lib/Repetier-Server/printer/iFactory3D__One_Pro $ sudo find / -iname modelGroups.json
    /var/lib/Repetier-Server/printer/iFactory3D__One_Pro/data/modelGroups.json
    pi@ONEPRO:/var/lib/Repetier-Server/printer/iFactory3D__One_Pro $ cat data/modelGroups.json
    {"files":[{"id":1,"p":"#"},{"id":2,"p":"#"},{"id":3,"p":"#"},{"id":4,"p":"#"},{"id":5,"p":"#"},{"id":7,"p":"#"},{"id":8,"p":"#"},{"id":9,"p":"#"},{"id":10,"p":"#"},{"id":11,"p":"#"},{"id":12,"p":"#"},{"id":13,"p":"#"},{"id":14,"p":"#"},{"id":15,"p":"#"},{"id":16,"p":"#"},{"id":17,"p":"#"}],"groups":["#"]}

    Edit: The gcode files were shown with 1.3.0 (so did this still accept "inf"?). Semantically infinite makes sense - it is a belt printer :)
  • edited November 15
    Good news, (after creating a backup) I manually deleted all files in the models folder and uploaded some gcode models again. Which works, these files are shown in the list as expected!
    Apparently the "delete all g-codes in this group" functionality didn't delete anything, but the manual approach worked.

    As soon as I upload the Benchy again, all entries disappear from the list. If I delete the Benchy from the models folder again and reboot the server they reappear.
    Odd thing is that other, own models that I also sliced with IdeaMaker don't seem to lead to the same problem - even though they also have "xMaxMove: inf" in their *.gin file. So perhaps the "inf" thing isn't the actual problem with the Benchy? (And as said, the Benchy worked with 1.3.0)
  • And bad news again: Even though the first self-sliced own model coincidentally worked, another one doesn't - it behaves like the Benchy, everything in the list disappears. So it seems to be hit and miss. I could do without the Benchy - but I need my own models to work.
  • I think it is something in your slicer result that is making it freak out. Unfortunately the benchy download is private. See PM with my email so I can test reason. Next release comes soon so would like to have it fixed there for all.

    Maybe it is related to belt printer. Did you select in shape that it is belt printer and select correct angle (45 i guess)? Maybe the transformation in combination is the problem, who knows. Belt has infinite z, but you should not set it. All prints start at z=0 so z length should just be size of belt at least in server. That is what looks best and you still see the object coming out and in to bed.

    1.4.3 had some improvements for belts and xMaxMove is also quite new. Should be biggest x position during print and that is not inf. But with some math error it might get inf, question is just how since illegal computation lead to NaN and inf is harder to create.
  • Mail sent, thanks for having a look! With direct printing I get correct results, which speaks for a correct configuration. (Yes, it prints at 45°, in IdeaMaker the infinite axis is y - not sure how this is mapped in gcode then) Have just started with first experiments with the printer, it came with Repetier Server pre-configured for this printer on the internal Raspberry Pi. For slicing I have been using the official iFactory One Pro PETG profile in IdeaMaker.
    Would be interesting to understand why it worked with Repetier Server 1.3.0. (I mainly updated because I had sometimes the issue that after stopping a print it immediately restarted unless I deleted the job from the print queue also . (The item was in the print queue with quantity 1). The printer support meant that this is a known problem, so I wanted to check whether this is already solved with the newest Repetier version. Initially 1.3.0 was preinstalled.)
  • At least the g-code looked perfect with z-axis being endless as it is supposed to be. So guess they convert it for slicing.
    > The printer support meant that this is a known problem
    I'm not aware of this issue. But we changed quite some belt issues in the 1.4.x stream including automaically printing next files in queue switch so you can use it like a factory.

    Let me know if it still happens and if there is a way to reproduce. Just tested in 1.4.4 2 files in queue and stoping one and no new job was started. Regardles if print next was on or off, which is good since manual stop means something is wrong normally.

  • The Repetier developer was able to reproduce the issue and sent me a fixed preliminary version, the fix is planned to go into the next release 1.4.4. Seems to be an issue with a gcode sequence that is only ocurring for belt printers.
    Thanks a lot for the fast analysis and fix!
Sign In or Register to comment.