Slic3r Plugin Problems.

Alright, so recently I update RepetierHost to the latest version, being V2.2.4. I've gone through this process a couple of times, and never ran into to many issues.

So, thinking that this is going to be like every other time I've ran through the set up process, I select the appropriate plugins for the Slicer of my chose, being Slic3r, and.... Nothing

For some reason, every time I try to use it, I keep getting the same error message of
<Slic3r> Assembly .  '/home/pacst3r1/Downloads/RepetierHost/plugins/SlicerSlic3r/SlicerSlic3r.dll' doesn't have an entry point.

I tried with SlicerSlic3rPE, and got the same message, with the appropriate differences. I tried deleting and re-installing Slic3r, ran through the set up again, same results. I've been at this for over a week now, and I've tried everything I can think of.

I'm the OS I'm using is Ubuntu V22.04.1 LTS, if that's need.


  • You should prefer the AppImage version. Looks like you are using the tar version, but here you depend more on installed mono version and I guess it is a issue with what is installed. That version also has the PrusaSLicer included so easier to get running.
  • Try running it through netfabb.

    I've had similar issues with STLs that have minor artifacts...

    Edit: at least this will tell us if it really is your slic3r or if it was something with the file.

Sign In or Register to comment.