MPCNC randomly wrong milling paths

Dear Members,

I have a problem. I own an MPCNC that has dual endstops and is controlled by a RAMPS board with Marlin firmware (V515 Marlin 2.1.1).

I use the Estlcam 11.244 software in combination with Repetier Host.

The whole setup works properly and can mill fine.

But now, while milling a random letter, he suddenly wants to choose a completely different route and suddenly starts milling a lot deeper, causing the project to break.

I have already tried the following:

  • Other Marlin firmware
  • Other speeds
  • Print via PC or via SDCard
  • I thought maybe I hitted the endstops but even that wasn’t the problem

Yet he continues to do this completely arbitrarily.

Anyone any idea?

In my latstest mill project what went wrong, Repetier Host showt the last messages:

10:35:38.305 : N3061 M140 S0*81
10:35:38.689 : echo:Unknown command: “M140 S0”

No idea if that has anything to do with it.

NOTE: Some random letters work perfectly, but even if i start them again it could break/crash.

Thanks for contributing ideas!


  • M140 S0 sets bed temperature to 0, so not relevant if that gets ignored.

    If sd card and host result in same error it is either g-code or interpretation of g-code. What might be problematic are very small arcs or arcs close to 360°. Here rounding errors can get strange results. But that would only cause wrong xy moves z move would still be ok, but you said it is not. If you can forbide very small arc moves (making them a line) and split 360° moves into two. Then rounding errors can be excluded. Show move path in host and see if you see the same move there.
Sign In or Register to comment.