Klipper Forked Version


Had a failed board on a Creality machine with the CR10S Pro Touchscreen.  Decided to get away from Creality boards and would like to install Klipper, with Repetier Server but still be able to use the touch screen.  Someone has done a fork of Klipper that can use said touch screen.  https://www.reddit.com/r/CR10/comments/ibckmm/klipper_with_support_for_the_cr10s_pro_touchscreen/

Is there a way to install a forked version of Klipper through the Repetier server GUI?  There is only the option to select the 2 versions.


Is there a way to manually install the forked version so Repetier Server acknowledges it is installed?  I tried manually installing, but Repetier Server still wants to install its own version.

Thank you.


  • Yes, you can do that. Simulate our installation but use different github url. Our installer runs this
    wget http://download1.repetier.com/files/server/extras/klipperInstaller.sh -O /tmp/klipperInstaller.sh
    bash /tmp/klipperInstaller.sh $1 $2 $3 $4
    rm /tmp/klipperInstaller.sh
    You see first line copies the installer from our server and second line calls it with 4 parameter. If you look into the script you see they are
    So first is your printer slug name, secong git target e.g. "master" for maste rbranch. Version is "1" and url must be the https url of the repository. For klippe rmaster this is "https://github.com/Klipper3d/klipper.git".

    Make sure to call all commands with sudo so it can change file owner to repetierserver. Then it should look like our installation just from other repository. Restart server eventually so we see the files.
  • Worked great.  Thank you!
  • Would this method be applicable to install a specific version of Klipper? I have a Voron 2.4 running a CAN-bus toolhead and couldn't get it working under Repetier, so I tried Mainsail and it worked there. now that I know I have it all configured right I wanted to migrate it all over to Repetier, but it gives me very strange faults. I thought it could be because of different Versions of Klipper on the MCU but havent seen any option to choose wich version I want to install other than 0.10.0 or latest... 
  • Since 0.10 is already old (over a year) and there is no newer version we did not add older version. In theory older version or other github forks should work. At least if they use the same commands/files for configuration. As you see in the solution we have a INSTALL_VERSION to handle different method, but so far 0.10 and master seem to be identical in handling.
Sign In or Register to comment.