Touchscreen not working after new install on Rpi

I have a Rpi 4 with a Waveshare capacitive touchscreen which used to work fine right out of the box.

Recently I ran into problems with my repetier server. Google Chrome always popped up with a privacy screen which I couldn't get rid of (I updated the image once per apt upgrade and what I have been reading in the forums that might be the cause for this.
So I decided to download a new image file and restored the setup from backup. (btw not a straigt forward operation)

First, I was surprised, that the camera settings weren't restored so I set them up manually.
The contents of the screen is now ok, but the touchscreen is unresponsive.
I have changed absolutely nothing not even a single usb connector but it still doesn't react.

The Rpi all in all seems to be much slower now.
Can anyone explain or speculate what is going on?



  • Just to make sure, I have just reinserted the old SD-card and the touchscreen ist just working fine again.

  • For touchscreen you needed to adjust settings I think for that display to calibrate it. Check waveshare installation instructions (xinput i think plus adding result in some config files). Guess that this or module for touch handling i snot loaded by default so it does not get the positions. Unfortunately there are a lot of different displays and touch screen solutions working a bit different with different drivers.

    The new image uses the new video driver by default. If you have pi cam it will use 100% cpu time now for conversion as it won't use hardware encoding then. You can run raspi-config and switch to legacy graphic driver that wa sused on old image.
  • Well, thanks, that is very inconvenient.
    I think I stick with the old image and try to fix it.

  • In old image you need to change autostart file somewhere /home/pi/.config/ some path with LXDE .
    It contains the chromium start and with
    chromium-browser --force-device-scale-factor=1 --disable-features=TranslateUI,Translate --app-auto-launched --disable-pinch --noerrdialogs --disable-suggestions-service --disable-translate --disable-save-password-bubble --disable-session-crashed-bubble --disable-infobars --touch-events=disabled --disable-gesture-typing --kiosk --check-for-update-interval=31536000 --remote-debugging-port=9222 &

    it should start without the extra windows.
  • Thanks, I‘ll try that
  • Well, it kinda seems to work, but the autostart file is in

Sign In or Register to comment.