Remove M107 command

Hello all, I have minor issue I'm hoping someone can help me with.

Any time I use Cura in Rep Host a M107 (fan off) command is added to my Gcode, first thing after my start Gcode.
I'm using this Gcode on my Makerbot rep2 (after conversion to X3G) the issue is that the fan it turns off is the one cooling the extruder. I have always gone in and manualy removed the M107 before saving the Gcode.

It seems no combination of checking/unchecking the Enable Cooling box (Rep-host Slicer tab) changing min/max fan speed, setting "fan full at height" or "minimum speed" (Cura Print/extrusion tab) will get rid of this command.

Anyone know what setting I can change to stop this command from getting added to my Gcode?

**** end of start.gcode ****)
;Layer count: 150
G0 F9000 X-1.844 Y-0.640 Z0.300
G0 X-2.828 Y0.845
G1 F2400 X-3.462 Y1.540 E0.05116


  • I created this account only so I could bump your question. I just started using Cura in RH and I can't get rid of that M107 line either. No matter what fan settings I put into the "printer config" or Cura "Full fan on height", Cura refuses to activate the fan during the print and inserts that M107 after waiting for temperature.

    Real bummer because this glitch forces me to be there to start my prints so I can manually click the fan button.
  • Please also check fan settings in used filament. Slicer uses the highest settings from the combined setting.
  • My filament "fan minimum" is 50% and max is 100%.

    The issue may be that there are 3 locations where the slicer can pull an m107 command from. The RH "printer config" start script could have an m107 (mine is m107 s255). The Cura start script has an m107 by default (I removed that line). And Cura "fan max on height" inserts an m107 before Layer 0.

    However, "fan max at height" never generates an m106 command on any layer of my resultant gcode. After removing all RH "printer config" gcode scripts, Cura still refuses to generate any m106 commands in the gcode.

    How can I get Cura to activate my fan? Can someone please send me a Cura settings file that works for them?
  • Wow! Do I feel silly.

    After much frustration I finally noticed the "enable cooling" radio button on the slicer tab...

    Problem solved!
  • Hey!...did same thing as Fragmaster... opened account just to comment here... and... found that in Cura Settings -> Print -> Extrusion -> Cooling section... is a "Fan full at height" setting that if set to anything higher than 0, cura generates that M107 command before layer 0...
Sign In or Register to comment.