Manual XYZ controls don't work from android chrome

I have noticed that after a print the manual controls in the web UI behave really strangely. Sometimes they don't work at all, sometimes they just do unexpected things. Not sure if this is a firmware thing or a server thing. By strangely I can give an example, after printing something I can home all the axis, if I then try to raise Z the X and Y axis move close to the middle of the print area and then finally Z raises. When this happens the location of X and Y are not updated in the UI but homing all axis afterwards shows that the firmware knows they moved because they go back home. Not sure if this could be related to me not using endstops of any kind. I have checked logs on the server and see noticed nothing out of the ordinary. Also, when the manual controls are not working at all from Android they do work from a desktop browser which makes things even more confusing to me. The extra XY moves also seem to happen from the desktop broser as well, and again the XY gauges in the UI don't reflect that they are actually moving(they stay at 0 and only Z goes up, but all 3 axis actually move).

Please help me troubleshoot if you have a few minutes, none of these problems are showstoppers but they are minorly inconvenient.


  • Any advice on this, I can consistently reproduce it by printing a single piece and then trying to manually move the axis afterward?
  • I will try after my current print on a delta. Only problem is I have no android here. And with chrome also the version may matter, so which version does it have?

    What printer type do you use?

    Are you using the sliders or the arrows for precise moves?

    One thing you could do for debugging is enabling the log and see if and which commands get send. Since printer only does what is being told the question here is, are the commands containing the strange coordinates or is the firmware interpretation wrong here (which I do not think or printing would be difficult).
  • I am running Chrome 45.0.2454.84, I am trying to use the slider on screen, I see no arrows. My printer is a CNC 3020 with an mk7 extruder setup, running repetier latest firmware. 

    How do I enable the debug logging?

    Printing works great BTW, just weird things happen after a print when you try to manually control it. Also, I have been playing with the @pause command in gcode, it seems like when it encounters the pause command the interface then shows "No job running" even after clicking the continue button. When you click continue the print finishes, but while it is finishing it still shows "No job running".

    I feel like I have been complaining about repetier alot, I want to let you know that this is some great software. I only want to make it better, so hopefully I don't sound like I am complaining about it to you. Good Job!!!
  • Enabling debugger for android chrome:

    not sure if this will show anything - but if you see errors except socket connection failed it may be a hint. Sometimes I also get that the sliders do not work but not reproducible and after reload it is always gone. I guess the flags allowing to move them get mixed up since you can not move them during print.

    Will check the pause command problem. Even in pause mode it should be visible. On the other side you can not use move etc in print mode so we have to disabale this a bit and I guess that removes the print message.
  • Just trying to find the pause problem, but everything worked as it should. Everywhere I saw the job running. At which place does it disappear? In home screen and printer list menu it shows it correctly. And continue button also appeared as expected.
  • The continue button only appears for me in the notifications area under the envelope icon. I don't see the job running in any screen while its paused or after resuming. I am running a job with an @pause command right now and will verify on a few devices to see if its device specific. Just to clarify though, this only happened when @pause was in the gcode not on a manual pause.

    Will update with my new findings shortly.
  • Yes same on all my devices, shows no job running though hitting continue in the notification will finish the print. While the print is finishing there is still no jobs shown, which makes it impossible to stop or pause again.

    Its kind of funny because you can fight with it by doing manual moves and it will make the manual move then go right back to finishing the print, still not showing a running job.
  • I just realized I am running the 0.91 version of the firmware, could these problems be related to not running the latest firmware?
  • It does not depend on firmware version. @pause is handled on server level and never reaches firmware.

    Main problem is that there seems to be a influence factor making it work or not that we do not know about. I have changed server side commands to work correctly already, but you said the pause started so that should not be the difference.

    Di you have any script set for pause that could explain wrong behaviour?
  • No, no script set. I did run a different job today that has a pause and it ran as expected, it showed the job running etc, so it must be something specific to the smaller job I ran last time. Both were sliced with slic3r, and then I manually added the @pause. Both time the pause worked, but on the smaller job it didn't show the job running after the pause, the larger on did. Also, the only way to resume on the smaller job was to click the envelope at the top and the play button next to the pause notification. The larger job had the notification, and a continue button in the job queue area. I know that gcode is somewhat machine dependant, but I can send you the 2 gcode files, and even the STL files if you think it would help to track down the issue.
  • edited September 2015
    Uh-oh just noticed something even more odd, the larger job is still running after the pause but when I look at the web interface on my Mac OSX it doesn't show any of my stored G-code files, when I look on my android it shows them all.

    Confuses things further I am sure, just passing along what I see.

    Reload the page on my Mac, by going back to Home and clicking on the printer again and now they show. idk what happened there lol, scared me for a sec I thought I lost all my files.
  • Sounds like I'm not totally crazy if it only happens on some files:-) So yes, please put the file where it happens somewhere to download so I can test what is going on.

    There is also a bug if files disappear after uploading. Only a restart of the server then helps. This has been fixed for next release.
  • I am not sure if I can attach a file on this forum, so I will upload it to my google drive later. It does seem to happen on other files as well, and it seems to only happen when there is not much time left after the pause. Today on a completely new file it happened to me when I manually paused, it actually showed the job in queue for a split second but then it disappeared, I thought I hit stop instead of pause by accident. I was still able to resume by using the notification area but it never showed back up in queue. In this case the job had less than 5 mins remaining when I paused, which should be pretty close to the time remaining when the jobs were paused via gcode previously. Give me a little while and I will upload the files I have.
  • Don't bother about the pause bug. I found it, just didn't find this thread cause of the headline not mentioning the pause:-)

    The problem arrises if your file has less then 5000 lines left. Then it has a wrong condition that says job is finished (because file was read to the end) but did not look at the remaining lines. It is fixed for next release.
  • edited November 2015
    Thanks!! Any ideas about the manual controls? If not, no biggie it works from the laptop just not the phone and tablet for some reason.
  • Yes, we could validate that sliders act strange after a print on android. So now I need to set up a development environment to find out why windows/mac chrome do it correct and android chrome not.
  • ok thx!! At least I know its not just my POS phone lol. Another kind of related question...I am noticing that the layer number is not updating in repetier-server in the control tab. It doesn't show the current layer nor the total number of layers. I tried verbose slicer output and regular and neither seems to help.
  • I remember this bug. Happens with some start code settings and I have fixed it for next release. Not sure any more what exactly it was that confused the layer count. I think it was extrusion in air before the print. New layers only started when you extruder higher which then did not happen. Something like that.
  • Awesome, any idea when the next release will be? Also, is the github content the current code base, can I build and install from there to always be up to date or are you managing the code somewhere else now?
  • 0.70.1 is out and all android problems I could produce are solved.

    No our sources are closed. The github version is quite old and gets no updates any more.
Sign In or Register to comment.