Connection breaks (becomes red) with the printer

Hi, I have Repetier-Server installed on Windows 7 Ultimate. I have two printers which are installed in two usb-ports. Printers are visible and seem to bee functioning in Windows Device manager. I have checked the ports are configured in RS according to ports in device manager. I have also tried with new usb-cables. My printers use Andciv CM3E 3D printer control boards (a little fancy hardware from China). The printer works very well in Cura, Slic3r, Simplify3D. I haven't seen any connection problems with those software.

My problem is as follows: The connection between printer and RS drops down after few minutes when the printing process is idle. Sometimes I  get the connection back on if I unplug the usb-cable or reboot the printer. Once I managed to print and control those two printers together for 24 hours when I finally got the printing to start. 


  • I had a similar problem on mac. There connections did not work after mac went into sleep mode. For windows I never had a problem with sleep mode. Connection was always alive and functioning after wakeup. While printing the server prevents windows sleep mode. Can you say if this happens when windows did went into standby? Also what chip/driver is needed for serial port on anciv boards?
  • Breaking down happens even windows is awake (not in standby). Windows driver is andciv-cm3.inf. Does this help?

  • Do you have a download link? I only found a chinese website which I didn't understand on how to download.

    Have you checked logs/server.log of the server for possible hints?
  • Yes indeed, there is only chinese website it can be downloaded:
    - You can download it from blue link on left with chinese text + (3.25KB).
    I can also send it by email if necessary.

    I keep on checking the logs, but haven't found anything yet.
  • It seems this irritating problem happens when I have two printers (with Andciv CM3E 3D motherboard) connected. When I have just one printer everything seems to be ok, but with two I get problems.
  • Do they get powered over usb? Then a active powered usb hub might help. Then 2 are too much for the computer also each output should be able to handle 500mA individually.
  • Andciv CM3E 3D gets power from 3D printers power supply, not from USB
  • The connection problem seems to be elsewhere. I changed to brand new Win 7 laptop and now the connection problem disappeared. There must be some technical issue with my original PC. I just don't know what...
  • Since it only happened with 2 identical boards connected, maybe these two got swapped internally somehow. Anyhow sound like a windows internal thing and maybe connecting to different usb ports would make a difference (not same hub), but htat is just guessing for a possible solution
  • I'm happy to announce that this issue is completely solved now! The problem was in my old computer. Now everything works well! This is really great software specially when operating in more than one printer and when print runs are very long! ^:)^
Sign In or Register to comment.