Any way to have repetier server NOT do anything at pause request?

I have a custom firmware that runs an M600 command when it detects filament is out.  Problem is the pause command is running and not allowing the firmware M600 command to run.  I have verified this by running the gcode right from printer w/ the usb unplugged vs. running the same gcode uploaded to repetier server.  I am seeing the following at filament runout which I would like to disable. Under pause actions I don't see an option to "do nothing" just just pause, and 3 others that can control timeouts.

10:08:50.880 : @pause Your printer requested a pause.
10:08:50.880 : //action:filament_runout T0
10:08:50.880 : @pause Your printer requested a pause.
10:08:50.880 : //action:pause filament_runout 0


Thanks

Dave

Comments

  • Are you using 1.4.1? There we added in connection command
    M412 H1 S1
    which tells firmware to not handle such thing son it's own but to ask host for it. After all
    //action:filament_runout T0
    is the designed message to make host software trigger a pause instead of internal using.
    You might want to add in run on connect
    M412 H0
    to disable host handling and enforce firmware handling.

    I'm quite sure I will remove that instruction on next update as it seems to make often problems e.g. firmwares having it without connected sensor and then triggering an error.
  • Yes, I am using 1.4.1  I will try M412 H0.  As of now I have set an event dependent run on pause M600 which is working. So you are saying you may remove your M412 H1 S1 to allow the FW to handle these things again on 1.4.2?

    Dave
  • Yes, thats the plan. Users can than still add it in run on connect if they want/need it. But no forcing it.
  • edited August 29
    Repetier said:
    Yes, thats the plan. Users can than still add it in run on connect if they want/need it. But no forcing it.
    Thats great thank you.  I was trying to figure out why all the sudden my M600s stopped working in FW.  I didn't recall recently installing 1.4.1 either but i guess i did.
  • But as said you can add in run on connect strip deactivating host handling of out of filament if that was the reason it changed. Or leave it to give server the control.
  • Yep I can and did test that method to ensure it would work for me.  For now though I just added M600 to the pause command.  Six of one, half a dozen of another.  

    Dave
Sign In or Register to comment.