G28 and G29 commands need to issue M114

There is a problem in Repetier-host (1.0.6) when homing X,Y, or Z. The software doesn't update when the axis move for homing. See my inital report against Merlin: https://github.com/MarlinFirmware/Marlin/issues/1502

Problem is if a G28/G29 is issued repetiet sets the Axis to 0 and then homes until it makes contact with an endstop. However, I'm using auto-bed-leveling and for that to work when the Z gets homed it has to move my Z-probe to the center of the bed. The X/Y movements don't get updated with the correct movement values but instead just stay at 0 for both X and Y.

Comments

  • edited May 4
    Reproducing this bug as well. Repetier-Host version 2.0.0 with Marlin RC8 (BugFix)

  • Doesn't happen with Repetier-Server Pro 0.80.3. After a G28 this piece *does* update its current location to the Safe-Home position the firmware has set.
  • Oh! Another update --
    The position updates on the Website, not in Repetier Host even when connected via IP to Repetier-Server
    image
  • In server you can define exact home position and not only min/max/0 which host uses. In next host release you can also set positions like in server for G28.

    M114 is not used to update host any more since there are cases where the response ha snot the expected coordinates and that also brings wrong coordinates.
  • Sorry, you are correct, M114 does indeed NOT update the coordinates in the host software. I linked here from another page and neglected to read the title of the bug and jumped to the conclusion that it was the same that I was seeing. Sorry :(

    Just to be clear though, this is a bug and Host guessing the location rather than getting it from the firmware is being fixed in the upcoming version? The host seemed to communicate with the printer software in previous versions before the upgrade to 2.0.0, or am I misunderstanding?

    Thanks!
  • If you were not printing host read M114 output. But newer firmwares change coordinate reference or use other output also with x: so it is not safe any more to reley on this. So now you enter the coordinates after homing in next release (since newer firmwares also have min z homing not stopping at 0 to protect bed or whyever users want it to stop higher).
  • Thanks for explaining it for me :D

    I really appreciate it :)
  • edited May 7
    And now how can you enter the coordinates after making G29 to Repetier Host if command M114 is not available?
  • G29 is not homing. You can always send a set of coordinates and the host command
    would set coordinates to homing position stored. So
    G1 X10 Y10 Z5 F6000

    would make coordinates black and correct as printer has moved to given position.
    For 2.0.1 I also add @ishomed which just makes the coordinates black if you want to fake homed coordinates.
  • What I do is perform the homing with G28 and then do the leveling of the bed with the G29 command. The printer, when finished, is in a position which is displayed on the printer screen but not on the host. And what I did was use the M114 to be able to move the printer from that position in which it stays, but the question is that I can not do G28 again because I lose the leveling.
    That is why you could have an option within the program in which the user can use that command because I worked perfectly and did not give me errors or anything.
    If there is another way to display the coordinates after leveling I would like to know how to do this if the M114 command is not allowed. Otherwise I will have to use an old version of repeater-host. :(
  • As I said problem is that firmwares do not report the same coordinates so if I put it back because it works for you others will claim that it is doing it wrong since coordinates do not match afterwards. That is why we removed it. Simple fix is send 
    G1 X10 Y10 Z10 F6000
    afterwards then both are in sync again. For print jobs this is also no big deal since they also use absolute positions.
Sign In or Register to comment.