Delta Printer configuration flawed in Repetier-Host 2.0.1

Hi,

how i am supposed to configure a Delta Printer in Repetier-Host 2.0.1?
In the Printerconfiguration i was able to set HomeZ to min/max/0 in 1.6.x
Now i can only enter a fix value? 
If i home the Printer the Z-Coordinate shows the value i entered. Not the Value the Firmware reports. Which is bad on a Delta with autoleveling and so on.

Comments

  • Yes, you now need to set the coordinates. In older host versions the coordinates were taken in some cases, but not always. But these answer is not correct any more for all firmwares so we removed reading them as this could occur on other things as well.

    That is normally no problem if it varies a few 0,01mm which is what autolevel would differ. Every gcode with absolute commands will correct this anyway. So the next non relative z move fixes is like the first layer in prints.
  • edited May 17
    Well, on a delta the z-height could vary a lot because of different build plates. But it is fine for me. 

    But what i really find annoying, is the fact that the host shows some coordinates which has absolut nothing to do with reality. Wouldn't it better if the host would send absolute coordinates and not relative? Or at least the first command which is send is in absolute coordinates so printer and printer-settings are equal and then it can continue with relative?

    And don't say now something like "use a script button which you click after homing". No, no, no. There are only 5 Script buttons and they have already other functions :smile:

    Which brings me to that: could you add more script buttons and make them a little configureable (e.g. change the icon, or link them to a custom command of the repetier-server)
  • One solution might be to send after using home buttons a G1 move to the assumed position so they fit. So entering a z height a bit too low but on safe side would work always. Have to think if that causes new complains from all users having set the coordinates wrong.Or allow coordinate reading once after homing as there is no G92 offset then that can confuse.
Sign In or Register to comment.