Preview Editor issue

Hi,

if I add Start GCode G92 Z200 Repetier Host shows the modell in the preview in Z -200:
image
In my eyes this is a bug. I've the same issue in Repetier Server. In Slic3r it doesn't show it like this.

Comments

  • Posts: 7
    GrillSgt said:
    Hi,

    if I add Start GCode G92 Z200 Repetier Host shows the modell in the preview in Z -200:
    image
    In my eyes this is a bug. I've the same issue in Repetier Server. In Slic3r it doesn't show it like this.

    I've checked the beta 2.0.0. Same behaviour.
  • edited April 18 Posts: 0
    preview plane shows coord Z=0, if you send G92 Z200  you shift this plane to coord Z=200.
    Your print starts for example at Z=0.2  which is now displayed as coordinate Z= -199.8

    from my point of view absolute correct.

    so what´s the reason for Start G-Code G92 Z200?
  • Posts: 0
    Exactyl, this is no bug. It is the gcode as you said. G92 shifts position where it gets printed and host just shows that fact.
  • Posts: 7
    I understand your point of view and aggree with you.
    The reason to send a G92 Z200 is that I lift Z to 200 after printing. As long, as no reset of the printer is needed everything is fine without G92, because M114 is Z200. But if the printer does a reset Z is 0 - which isn't the truth.
    Because of this my idea was to tell the printer Z is already on 200. After this Z is going down to 0.2.
    I know  the simplest solution would be to home all axis including Z, but can't home Z before printing because I'm using a Z-probe and see no chance at the moment to mount a hardware endstop at Z-max.


  • Posts: 0
    You can still home to z min using z probe. At least in dev firmware this is working good.

    In any case host shows it correctly since it does not know you are fooling the printer. It will still send commands correctly and unchanged. 
  • Posts: 7
    That sounds intresting. Is there some special configuration needed in DEV firmware to use it? Or is it documented anywhere?
    Repetier said:
    You can still home to z min using z probe. At least in dev firmware this is working good.
  • Posts: 0
    In config tool upload old config from 0.92 config tool and it will upgrade, You need to set z min endstop pin = z probe endstop pin so firmware detects this special case. Use homing order XYPreheatZ with preheat temp. 0. This allows setting probe position since activating probe moves it and that is often not possible at xy home pos.
  • edited April 19 Posts: 7
    Thanks. I already tried it, and it worked like a charm. Some old config settings was not applied in your config tool after uploading my old configuration.h, but I've manually editted it. It works very well :)

    greets from Solingen.
Sign In or Register to comment.