Extruder offsets

Running v.92, using the following:  EXT0_Y_OFFSET 2700, in configuration.h and I confirmed with Repetier Host the same value is in EEPROM.

My understanding was this told the firmware where the bed was in relationship to 0.  So in my case after a Y home, the bed is 2700 steps away.

When running a G32, the extruder moves to the corrected location based on this offset.

But when I try to print something, there's no offset.

In the UI, I noticed under Position/Set Print Offset there's a setting for axis offsets.  These always default to 0mm.  I see no way in configuration.h or in EERPOM to save these.  Setting the offset here doesn't do anything.  I tried both positive and negative numbers and it always prints in the same location on this axis.

Comments

  • Posts: 0
    Normally you set extruder 0 offset 0 so it is the origin of all extruder and z probe offset. This is not meant to define any positions relative to homing. That is what xmin/ymin and x,y length are for. After homing you are either at xymin or max depending on homing position. 

    The print offset is the equivalent to G92 and only temporary until next homing.
  • Posts: 0
    EXT0_Y_OFFSET değerinin ekstrüder etkisi nedir?
    Where can I find out the extruder values in the EEPROM registration files?
  • Posts: 4
    So if I change this line:  #define Y_MIN_POS 0 to something else, when I do a home, it will set Y to the value set by this statement?
  • Posts: 0
    Yes, that should happen.
Sign In or Register to comment.