Weird autoleveling issue

Hello,

I've been using repetier firmware on my prusa I3 for a few months now, using repetier slicer.

I have an induction sensor for bed leveling, that was tuned OK.

Everything working with a 2 to 1 extruder Cyclops.

Yesterday I made a few changes to a classic 2 to 2 dual extruder.

The bed leveling still starts at the beginning of a print, print start ok, but after a few seconds on first layer, I can see the Z goes up, and up, and up. 

I don't understand why this happens.

Here's a copy of my start GCODE and my EEprom settings:

; Default start code
G28 ; Home extruder
G1 Z15 F{Z_TRAVEL_SPEED}
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
{IF_BED}M190 S{BED}
G1 X30 Y0 ; moving x and y before leveling
G32 ; Auto leveling

; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
{IF_EXT1}M104 T1 S{TEMP1}
G92 E0 ; Reset extruder position
G92 E1 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}
{IF_EXT1}M109 T1 S{TEMP1}




image

image

image

Comments

  • Posts: 0
    Make sure ALWAYS_CHECK_ENDSTOPS 0 since the sensor can trigger and prevent z down moves during z hops. That would be a typical reason when z increases during print.
  • Posts: 12
    Thank you very much! I forgot that parameter.

    I wonder why it didn't stay at 0 as I loaded my previous configuration.h file into the repetier configuration tool.
Sign In or Register to comment.