Why does Repetier Host display a blank white screen in 3D view?

I just installed Repetier Host and I can't get a 3D screen to display. It is a blank white screen on that side of the window. It works fine on one of my computers running Windows 8, but on the one attached to my printer is does not. Any suggestions on what the problem could be?

Best Answer

  • Posts: 0 Answer ✓
    That is most likely a problem with OpenTK and your opengl driver. Next release gets a newer version of opentk that is known to work with more drivers and hopefully fixes it. For now you might test installing host with legacy OpenTK version instead which works on some drivers the other version does not work.

Answers

  • Thanks for the response. How do I find Repetier Host with legacy OpenTK version? I checked (and searched) on the Repetier website, but I couldn't find anything that seemed to be it?
  • I did further searching and found the legacy version. Trying it now. Thanks!
  • The legacy versions on your website didn't work. Back to the drawing board for me. I'll have to see how to get around this obstacle.
  • Posts: 0
    Hi I have this problem too. plz help if you found a way.
  • Posts: 0
    Please try our beta. It uses a newer OpenTK version that was reported to solve such problems on newer drivers

    https://dl.dropboxusercontent.com/u/74036902/setupRepetierHost_2_0_0.exe

    Note that it is in development but should be stable for printing. Only some new features are not working 100% as supposed.
Sign In or Register to comment.