The estimated time in repetier shows up negative

So I've been using repetier for a few weeks now and every time I go to print something after slicing the estimated duration of the print shows up as negative.  Usually -8 seconds of -55 seconds.  Does anyone know what is causing this or how to fix it?


  • Are you printing over server or host directly?

    Can you provide a small example of the gcode? In server there was a command that resets time resulting in wrong prediction, so maybe you had a similar thing here.
  • I am printing form the host directly and here is a sample of my gcode.

    ; generated by Slic3r 1.2.9 on 2016-06-29 at 06:22:11

    ; external perimeters extrusion width = 0.20mm
    ; perimeters extrusion width = 0.20mm
    ; infill extrusion width = 0.20mm
    ; solid infill extrusion width = 0.20mm
    ; top infill extrusion width = 0.20mm
    ; support material extrusion width = 0.20mm

    M190 S60 ; set bed temperature
    M104 S205 ; set temperature
    G28 X0 Y0
    G28 Z0
    M109 S205 ; wait for temperature to be reached
    G21 ; set units to millimeters
    G90 ; use absolute coordinates
    M82 ; use absolute distances for extrusion
    G92 E0
    G1 E-1.00000 F1800.00000
    G92 E0
    G1 Z0.150 F3000.000
    G1 X106.526 Y61.842 F3000.000
    G1 E1.00000 F1800.00000
    G1 X108.996 Y58.165 E1.17311 F900.000
    G1 X109.709 Y57.370 E1.21483
  • That code shows 3s what does it show for you?

    I guess it happens only with the complete code, not just the first 20 lines. You can push the binary to so I can download it for testing. Would be great to know what time it predicts for you in gcode preview.
  • Here is the pastebin link to the gcode.
    Here is a screenshot of the time display.

  • Can't really explain why this happens. Found some problems when switching printers or removing gcode which did not update preview and gcode editor, but that was because no negative times are allowed and get ignored. Your sample gcode shows up as 51m 27s and not negative as for you. So currently the problem is not reproducable for me.

    Does Edit G-Code show the same negative value and keeps it when you change a line, e.g. a comment?

    What windows version are you using?
  • It does keep the same values when I remove parts of the code and I am running the lastest version of Windows 10.
  • Are you using 1.6.2 version or an older version. I fixed something time related a while ago, so maybe that is what you see here. Apart from this I also run W10, so same gcode and same os.
  • I was using version 1.61 but I just updated to version 1.62 and the problem is persisting

  • did any one resolve this ? 
    got same thing .  ETE -55s
    under slicer Preview estimated printing time -8s 

    I think it has something to do with slicer not sure what tho
  • okay it is slicer at least it was for me. 

    under Retraction Speed: set to 0 

  • Recently had the same error on mac version. F0 was really a problem as this gets infinite time breaking time computation. Same error was on windows host. Fixed for next release but with correct slicer setting it would not have happened.
  • I have to keep retraction speed at 0 if I don't i'll retract filament back way too much so infill starts laying half way into it. 

    maybe I got something wrong somewhere in the settings but 0 works great except ETA time always stays at -55:-(
  • Sure it only influences time prediction. Host sends commands unchanged it is not up to host to modify anything.

    Anyhow the printer is not using 0 or it would not retract at all. Retraction speed is the fastest and easiest move and it definitely is a positive number, so set it and it should still print ok. No need to set it to 100mm/s if that is too fast. It also can not retract more then you say. What might happen is tha afterwords you have oozed a bit and it needs a bit more filament to get it printing again. Slicers have a option for this to add extra extrusion after retraction. In general you want fast retraction for better prints so better retract fast and correct accordingly afterwards.
Sign In or Register to comment.